summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMaxim Biro <nurupo.contributions@gmail.com>2017-02-24 00:19:42 -0500
committerMaxim Biro <nurupo.contributions@gmail.com>2017-03-01 20:43:30 -0500
commit61c3b47bef5d1b3d86b2f948ffb17c5477733916 (patch)
tree9aaf6cb00f065d1cf328d8737412fbba409fcbac /CMakeLists.txt
parentaaca8251c8586c07814fb1b91482d35bc6cadd78 (diff)
Disable -Wdisabled-macro-expansion
Due to clang's tolower() macro being recursive.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 201358ef..ded86010 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -95,6 +95,8 @@ if(NOT "${CMAKE_CXX_COMPILER_ID}" STREQUAL "MSVC")
95 add_flag("-Wno-cast-align") 95 add_flag("-Wno-cast-align")
96 add_flag("-Wno-conversion") 96 add_flag("-Wno-conversion")
97 add_flag("-Wno-covered-switch-default") 97 add_flag("-Wno-covered-switch-default")
98 # Due to clang's tolower() macro being recursive https://github.com/TokTok/c-toxcore/pull/481
99 add_flag("-Wno-disabled-macro-expansion")
98 add_flag("-Wno-documentation-deprecated-sync") 100 add_flag("-Wno-documentation-deprecated-sync")
99 add_flag("-Wno-format-nonliteral") 101 add_flag("-Wno-format-nonliteral")
100 add_flag("-Wno-missing-field-initializers") 102 add_flag("-Wno-missing-field-initializers")