summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bf709e72..07098391 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,6 +2,10 @@ cmake_minimum_required(VERSION 2.6.0)
2 2
3set(CMAKE_MODULE_PATH ${PROJECT_SOURCE_DIR}/cmake) 3set(CMAKE_MODULE_PATH ${PROJECT_SOURCE_DIR}/cmake)
4 4
5if(UNIX)
6 find_package(Curses REQUIRED)
7endif()
8
5if(NOT WIN32) 9if(NOT WIN32)
6 option(USE_NACL "Use NaCl library instead of libsodium") 10 option(USE_NACL "Use NaCl library instead of libsodium")
7endif() 11endif()
@@ -29,15 +33,15 @@ if(NOT USE_NACL)
29endif() 33endif()
30 34
31macro(linkCoreLibraries exe_name) 35macro(linkCoreLibraries exe_name)
32 add_dependencies(${exe_name} core) 36 add_dependencies(${exe_name} toxcore)
33 if(WIN32) 37 if(WIN32)
34 include_directories(${CMAKE_HOME_DIRECTORY}/sodium/include/) 38 include_directories(${CMAKE_HOME_DIRECTORY}/sodium/include/)
35 target_link_libraries(${exe_name} core 39 target_link_libraries(${exe_name} toxcore
36 ${CMAKE_SOURCE_DIR}/sodium/lib/libsodium.a 40 ${CMAKE_SOURCE_DIR}/sodium/lib/libsodium.a
37 ws2_32) 41 ws2_32)
38 else() 42 else()
39 include_directories(${SODIUM_INCLUDE_DIR}) 43 include_directories(${SODIUM_INCLUDE_DIR})
40 target_link_libraries(${exe_name} core 44 target_link_libraries(${exe_name} toxcore
41 ${LINK_CRYPTO_LIBRARY}) 45 ${LINK_CRYPTO_LIBRARY})
42 46
43 endif() 47 endif()