summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4d049bc8..60d63098 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -610,6 +610,11 @@ endif()
610# 610#
611# :: Strict ABI 611# :: Strict ABI
612# 612#
613# Enabling the STRICT_ABI flag will generate and use an LD version script.
614# It ensures that the dynamic libraries (libtoxcore.so, libtoxav.so) only
615# export the symbols that are defined in their public API (tox.h and toxav.h,
616# respectively).
617#
613################################################################################ 618################################################################################
614 619
615function(make_version_script header ns lib) 620function(make_version_script header ns lib)