summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 0 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1585b8dc..add544ef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -129,11 +129,6 @@ if(MIN_LOGGER_LEVEL)
129 add_definitions(-DMIN_LOGGER_LEVEL=LOG_${MIN_LOGGER_LEVEL}) 129 add_definitions(-DMIN_LOGGER_LEVEL=LOG_${MIN_LOGGER_LEVEL})
130endif() 130endif()
131 131
132option(ASSOC_DHT "Enable module to store currently unused ID <=> IP associations" OFF)
133if(ASSOC_DHT)
134 add_definitions(-DENABLE_ASSOC_DHT=1)
135endif()
136
137option(ASAN "Enable address-sanitizer to detect invalid memory accesses" OFF) 132option(ASAN "Enable address-sanitizer to detect invalid memory accesses" OFF)
138if(ASAN) 133if(ASAN)
139 set(SAFE_CMAKE_REQUIRED_LIBRARIES "${CMAKE_REQUIRED_LIBRARIES}") 134 set(SAFE_CMAKE_REQUIRED_LIBRARIES "${CMAKE_REQUIRED_LIBRARIES}")
@@ -231,8 +226,6 @@ add_module(toxdht
231 toxcore/DHT.h 226 toxcore/DHT.h
232 toxcore/LAN_discovery.c 227 toxcore/LAN_discovery.c
233 toxcore/LAN_discovery.h 228 toxcore/LAN_discovery.h
234 toxcore/assoc.c
235 toxcore/assoc.h
236 toxcore/ping.c 229 toxcore/ping.c
237 toxcore/ping.h 230 toxcore/ping.h
238 toxcore/ping_array.c 231 toxcore/ping_array.c
@@ -375,7 +368,6 @@ function(auto_test target)
375endfunction() 368endfunction()
376 369
377auto_test(TCP) 370auto_test(TCP)
378auto_test(assoc)
379auto_test(conference) 371auto_test(conference)
380auto_test(crypto) 372auto_test(crypto)
381auto_test(dht) 373auto_test(dht)