diff options
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-x | CMakeLists.txt | 8 |
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index c0fea1a1..86b5d27b 100755 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -10,6 +10,14 @@ else() | |||
10 | option(USE_NACL "Use NaCl library instead of libsodium") | 10 | option(USE_NACL "Use NaCl library instead of libsodium") |
11 | endif() | 11 | endif() |
12 | 12 | ||
13 | #OS X specific | ||
14 | if(APPLE) | ||
15 | set(CMAKE_LIBRARY_PATH ${CMAKE_LIBRARY_PATH} /opt/local/lib) | ||
16 | set(CMAKE_INCLUDE_PATH ${CMAKE_INCLUDE_PATH} /opt/local/include) | ||
17 | set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -I/opt/local/include" ) | ||
18 | set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -L/opt/local/lib") | ||
19 | endif() | ||
20 | |||
13 | if(UNIX) | 21 | if(UNIX) |
14 | find_package(Curses REQUIRED) | 22 | find_package(Curses REQUIRED) |
15 | endif() | 23 | endif() |