diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 6b99510f..4544a91a 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -456,7 +456,7 @@ function(auto_test target) | |||
456 | toxnetcrypto | 456 | toxnetcrypto |
457 | ${CHECK_LIBRARIES}) | 457 | ${CHECK_LIBRARIES}) |
458 | if(NOT ARGV1 STREQUAL "DONT_RUN") | 458 | if(NOT ARGV1 STREQUAL "DONT_RUN") |
459 | add_test(NAME ${target} COMMAND auto_${target}_test) | 459 | add_test(NAME ${target} COMMAND ${CROSSCOMPILING_EMULATOR} auto_${target}_test) |
460 | set_tests_properties(${target} PROPERTIES TIMEOUT "${TEST_TIMEOUT_SECONDS}") | 460 | set_tests_properties(${target} PROPERTIES TIMEOUT "${TEST_TIMEOUT_SECONDS}") |
461 | endif() | 461 | endif() |
462 | endif() | 462 | endif() |
@@ -471,7 +471,7 @@ if(BUILD_TOXAV) | |||
471 | ${OPUS_LIBRARIES} | 471 | ${OPUS_LIBRARIES} |
472 | ${VPX_LIBRARIES} | 472 | ${VPX_LIBRARIES} |
473 | ${toxcore_PKGCONFIG_LIBS}) | 473 | ${toxcore_PKGCONFIG_LIBS}) |
474 | add_test(NAME monolith COMMAND auto_monolith_test) | 474 | add_test(NAME monolith COMMAND ${CROSSCOMPILING_EMULATOR} auto_monolith_test) |
475 | 475 | ||
476 | if(ANDROID_CPU_FEATURES) | 476 | if(ANDROID_CPU_FEATURES) |
477 | target_compile_definitions(auto_monolith_test PRIVATE -Dtypeof=__typeof__) | 477 | target_compile_definitions(auto_monolith_test PRIVATE -Dtypeof=__typeof__) |