summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 07098391..f2657fc5 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -25,11 +25,11 @@ if(NOT WIN32)
25 message(STATUS "==== ${CMAKE_C_COMPILER_ID} detected - Adding compiler flags ====") 25 message(STATUS "==== ${CMAKE_C_COMPILER_ID} detected - Adding compiler flags ====")
26 set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Werror") 26 set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Werror")
27 endif() 27 endif()
28 find_package(SODIUM REQUIRED)
29endif() 28endif()
30 29
31if(NOT USE_NACL) 30if(NOT USE_NACL)
32 set(LINK_CRYPTO_LIBRARY ${SODIUM_LIBRARY}) 31 find_package(SODIUM REQUIRED)
32 set(LINK_CRYPTO_LIBRARY ${SODIUM_LIBRARY})
33endif() 33endif()
34 34
35macro(linkCoreLibraries exe_name) 35macro(linkCoreLibraries exe_name)