summaryrefslogtreecommitdiff
path: root/xdelta3/Makefile.am
diff options
context:
space:
mode:
authorjosh.macdonald <jmacd@users.noreply.github.com>2013-01-20 08:57:36 +0000
committerjosh.macdonald <jmacd@users.noreply.github.com>2013-01-20 08:57:36 +0000
commitdf1e90ee3c130ad7b89d2273c2b0d53cab42d6f1 (patch)
treea037af01cd708b90a597a0e6f0e3ad30127d5b45 /xdelta3/Makefile.am
parent90e1af8f3e1867c33f86fe9ceccbaada01e8caef (diff)
Fix some TODOs (option_srcwinsz up to 4GB?
Diffstat (limited to 'xdelta3/Makefile.am')
-rw-r--r--xdelta3/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/xdelta3/Makefile.am b/xdelta3/Makefile.am
index 2b35e65..8283663 100644
--- a/xdelta3/Makefile.am
+++ b/xdelta3/Makefile.am
@@ -39,7 +39,7 @@ WFLAGS = -Wall -Wshadow -fno-builtin -Wextra -Wsign-compare \
39 -Wextra -Wno-unused-parameter 39 -Wextra -Wno-unused-parameter
40 40
41C_WFLAGS = $(WFLAGS) -pedantic -std=c99 41C_WFLAGS = $(WFLAGS) -pedantic -std=c99
42CXX_WFLAGS = $(WFLAGS) -pedantic 42CXX_WFLAGS = $(WFLAGS)
43 43
44common_CFLAGS = \ 44common_CFLAGS = \
45 -DGENERIC_ENCODE_TABLES=0 \ 45 -DGENERIC_ENCODE_TABLES=0 \
@@ -54,7 +54,8 @@ if DEBUG_SYMBOLS
54 common_CFLAGS += -g 54 common_CFLAGS += -g
55endif 55endif
56 56
57xdelta3_CFLAGS = $(C_WFLAGS) $(common_CFLAGS) -DXD3_DEBUG=1 57# For additional debugging, add -DXD3_DEBUG=1, 2, 3, ...
58xdelta3_CFLAGS = $(C_WFLAGS) $(common_CFLAGS) -DXD3_DEBUG=0
58xdelta3_LDADD = -lm 59xdelta3_LDADD = -lm
59 60
60xdelta3decode_CFLAGS = \ 61xdelta3decode_CFLAGS = \