summaryrefslogtreecommitdiff
path: root/xdelta3/Makefile.am
diff options
context:
space:
mode:
authorJosh MacDonald <josh.macdonald@gmail.com>2015-09-29 23:56:19 -0700
committerJosh MacDonald <josh.macdonald@gmail.com>2015-09-29 23:56:19 -0700
commitf63acfe3692478b983df1473bc1e7a1df3397b7f (patch)
tree7d6b42074cbb49e697b4536b5f2434f5eb4fd756 /xdelta3/Makefile.am
parent1e7f716f0854ad67df9a77341a829c84e4e6b1e5 (diff)
parentc6493c5a57e1edc95fa27123e86fe14c3695f284 (diff)
Merge from HEAD
Diffstat (limited to 'xdelta3/Makefile.am')
-rw-r--r--xdelta3/Makefile.am11
1 files changed, 4 insertions, 7 deletions
diff --git a/xdelta3/Makefile.am b/xdelta3/Makefile.am
index ffc35a4..322d88d 100644
--- a/xdelta3/Makefile.am
+++ b/xdelta3/Makefile.am
@@ -43,8 +43,7 @@ xdelta3checksum_SOURCES = $(common_SOURCES) \
43# Note: for extra sanity checks, enable -Wconversion. Note there 43# Note: for extra sanity checks, enable -Wconversion. Note there
44# are a lot of false positives. 44# are a lot of false positives.
45WFLAGS = -Wall -Wshadow -fno-builtin -Wextra -Wsign-compare \ 45WFLAGS = -Wall -Wshadow -fno-builtin -Wextra -Wsign-compare \
46 -Wno-unused-parameter -Wformat # -Wconversion 46 -Wno-unused-parameter -Wformat -Wno-unused-function # -Wconversion
47
48 47
49C_WFLAGS = $(WFLAGS) -pedantic -std=c99 48C_WFLAGS = $(WFLAGS) -pedantic -std=c99
50CXX_WFLAGS = $(WFLAGS) 49CXX_WFLAGS = $(WFLAGS)
@@ -53,7 +52,6 @@ common_CFLAGS = \
53 -DREGRESSION_TEST=1 \ 52 -DREGRESSION_TEST=1 \
54 -DSECONDARY_DJW=1 \ 53 -DSECONDARY_DJW=1 \
55 -DSECONDARY_FGK=1 \ 54 -DSECONDARY_FGK=1 \
56 -DXD3_POSIX=1 \
57 -DXD3_MAIN=1 55 -DXD3_MAIN=1
58 56
59if DEBUG_SYMBOLS 57if DEBUG_SYMBOLS
@@ -91,10 +89,11 @@ xdelta3checksum_CFLAGS = \
91man1_MANS = xdelta3.1 89man1_MANS = xdelta3.1
92 90
93EXTRA_DIST = \ 91EXTRA_DIST = \
92 README.md \
93 run_release.sh \
94 draft-korn-vcdiff.txt \ 94 draft-korn-vcdiff.txt \
95 README \
96 examples/Makefile \ 95 examples/Makefile \
97 examples/README \ 96 examples/README.md \
98 examples/checksum_test.cc \ 97 examples/checksum_test.cc \
99 examples/compare_test.c \ 98 examples/compare_test.c \
100 examples/encode_decode_test.c \ 99 examples/encode_decode_test.c \
@@ -115,8 +114,6 @@ EXTRA_DIST = \
115 examples/iOS/xdelta3-ios-test/xdelta3-ios-test/main.m \ 114 examples/iOS/xdelta3-ios-test/xdelta3-ios-test/main.m \
116 examples/iOS/xdelta3-ios-test/xdelta3-ios-test/xdelta3-ios-test-Info.plist \ 115 examples/iOS/xdelta3-ios-test/xdelta3-ios-test/xdelta3-ios-test-Info.plist \
117 examples/iOS/xdelta3-ios-test/xdelta3-ios-test/xdelta3-ios-test-Prefix.pch \ 116 examples/iOS/xdelta3-ios-test/xdelta3-ios-test/xdelta3-ios-test-Prefix.pch \
118 Makefile.mingw \
119 Makefile.orig \
120 testing/xdelta3-regtest.py \ 117 testing/xdelta3-regtest.py \
121 testing/xdelta3-test.py \ 118 testing/xdelta3-test.py \
122 xdelta3.1 \ 119 xdelta3.1 \