diff options
author | josh.macdonald <jmacd@users.noreply.github.com> | 2007-02-18 02:41:57 +0000 |
---|---|---|
committer | josh.macdonald <jmacd@users.noreply.github.com> | 2007-02-18 02:41:57 +0000 |
commit | cb24126c313a791a0705a2ecb740ab373cc5a612 (patch) | |
tree | 96b31c24f34652d646d2b9cf382cfe142bce6d16 /xdelta3/setup.py | |
parent | f6cfb03ce353ba50c4d8d981014c038acc363e10 (diff) |
raise default sprevsz, add command-line flag -P to set
Diffstat (limited to 'xdelta3/setup.py')
-rw-r--r-- | xdelta3/setup.py | 14 |
1 files changed, 5 insertions, 9 deletions
diff --git a/xdelta3/setup.py b/xdelta3/setup.py index f89aba7..abc902d 100644 --- a/xdelta3/setup.py +++ b/xdelta3/setup.py | |||
@@ -22,14 +22,8 @@ from distutils.util import get_platform | |||
22 | # External compression support works on Windows/Cygwin, but not from | 22 | # External compression support works on Windows/Cygwin, but not from |
23 | # within the Python module. It's something to do with fork() and | 23 | # within the Python module. It's something to do with fork() and |
24 | # exec() support. | 24 | # exec() support. |
25 | platform = get_platform() | 25 | #platform = get_platform() |
26 | is_cygwin = platform.startswith('cygwin') | 26 | #is_cygwin = platform.startswith('cygwin') |
27 | extcomp = 1 | ||
28 | |||
29 | if is_cygwin: | ||
30 | print 'Note: not compiling external compression support for Python/Cygwin' | ||
31 | extcomp = 0 | ||
32 | #end | ||
33 | 27 | ||
34 | xdelta3_ext = Extension('xdelta3main', | 28 | xdelta3_ext = Extension('xdelta3main', |
35 | ['xdelta3.c'], | 29 | ['xdelta3.c'], |
@@ -41,7 +35,9 @@ xdelta3_ext = Extension('xdelta3main', | |||
41 | ('XD3_POSIX',1), | 35 | ('XD3_POSIX',1), |
42 | ('XD3_USE_LARGEFILE64',1), | 36 | ('XD3_USE_LARGEFILE64',1), |
43 | 37 | ||
44 | ('EXTERNAL_COMPRESSION',extcomp), | 38 | # the fork/exec stuff doesn't |
39 | # work inside python. | ||
40 | ('EXTERNAL_COMPRESSION',0), | ||
45 | 41 | ||
46 | ('REGRESSION_TEST',0), | 42 | ('REGRESSION_TEST',0), |
47 | ('SECONDARY_FGK',0), | 43 | ('SECONDARY_FGK',0), |