summaryrefslogtreecommitdiff
path: root/xdelta3/setup.py
diff options
context:
space:
mode:
authorjosh.macdonald <jmacd@users.noreply.github.com>2007-02-05 10:30:28 +0000
committerjosh.macdonald <jmacd@users.noreply.github.com>2007-02-05 10:30:28 +0000
commitd3ab114a4f748456e63fbd0f19c89d52c8d740ae (patch)
tree0e52bceaff48d99f8096f6bd84bc05c4fe1bf276 /xdelta3/setup.py
parent29ec813ed97ebd4a02d594bb2a07f570ee1f604b (diff)
Add a .swig for python, working on xd3_encode_mememory() and
xd3_decode_memory(). Not working. Progress on scoring in xdelta3-regtest.py. Update FAST encoder w/ results of 9,11,13,16-llook experiments.
Diffstat (limited to 'xdelta3/setup.py')
-rwxr-xr-xxdelta3/setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/xdelta3/setup.py b/xdelta3/setup.py
index faee42b..24b80de 100755
--- a/xdelta3/setup.py
+++ b/xdelta3/setup.py
@@ -31,7 +31,7 @@ if is_cygwin:
31 extcomp = 0 31 extcomp = 0
32#end 32#end
33 33
34xdelta3_ext = Extension('xdelta3', 34xdelta3_ext = Extension('xdelta3main',
35 ['xdelta3.c'], 35 ['xdelta3.c'],
36 define_macros = [ 36 define_macros = [
37 ('PYTHON_MODULE',1), 37 ('PYTHON_MODULE',1),
@@ -56,6 +56,6 @@ REL='0n'
56 56
57# This provides xdelta3.main(), which calls the xdelta3 command-line main() 57# This provides xdelta3.main(), which calls the xdelta3 command-line main()
58# from python. 58# from python.
59setup(name='xdelta3', 59setup(name='xdelta3main',
60 version=REL, 60 version=REL,
61 ext_modules=[xdelta3_ext]) 61 ext_modules=[xdelta3_ext])