diff options
Diffstat (limited to 'xdelta1/configure.in')
-rw-r--r-- | xdelta1/configure.in | 91 |
1 files changed, 0 insertions, 91 deletions
diff --git a/xdelta1/configure.in b/xdelta1/configure.in deleted file mode 100644 index 76a71f4..0000000 --- a/xdelta1/configure.in +++ /dev/null | |||
@@ -1,91 +0,0 @@ | |||
1 | dnl -*-Mode: C; comment-start: "dnl "-*- | ||
2 | dnl Process this file with autoconf to produce a configure script. | ||
3 | AC_REVISION([configure.in,v 1.2 1998/10/03 00:17:50 jmacd Exp])dnl | ||
4 | AC_INIT(xdelta.c) | ||
5 | AM_CONFIG_HEADER(config.h) | ||
6 | |||
7 | dnl $Format: "AM_INIT_AUTOMAKE(xdelta, $ReleaseVersion$, no-define)" $ | ||
8 | AM_INIT_AUTOMAKE(xdelta, 1.1.4, no-define) | ||
9 | |||
10 | AM_MAINTAINER_MODE | ||
11 | |||
12 | DEBUGFLAG= | ||
13 | PROFILEFLAG= | ||
14 | |||
15 | AC_ARG_ENABLE(debug, [ --enable-debug turn on debugging [default=no]]) | ||
16 | AC_ARG_ENABLE(profile, [ --enable-profile turn on profiling [default=no]]) | ||
17 | |||
18 | TMPCFLAGS="$CFLAGS" | ||
19 | CFLAGS= | ||
20 | |||
21 | AC_PROG_CC | ||
22 | AC_PROG_CPP | ||
23 | |||
24 | CFLAGS=$TMPCFLAGS | ||
25 | |||
26 | changequote(,)dnl | ||
27 | if test "x$GCC" = "xyes"; then | ||
28 | case " $CFLAGS " in | ||
29 | *[\ \ ]-Wall[\ \ ]*) ;; | ||
30 | *) CFLAGS="$CFLAGS -Wall" ;; | ||
31 | esac | ||
32 | |||
33 | if test "x$enable_debug" = "xyes"; then | ||
34 | DEBUGFLAG="-g" | ||
35 | fi | ||
36 | |||
37 | if test "x$enable_profile" = "xyes"; then | ||
38 | PROFILEFLAG="-pg" | ||
39 | fi | ||
40 | |||
41 | if test -n "$DEBUGFLAG"; then | ||
42 | case " $CFLAGS " in | ||
43 | *[\ \ ]$DEBUGFLAG[\ \ ]*) ;; | ||
44 | *) CFLAGS="$DEBUGFLAG $CFLAGS" ;; | ||
45 | esac | ||
46 | else | ||
47 | case " $CFLAGS " in | ||
48 | *[\ \ ]-O[0-9\ \ ]*) ;; | ||
49 | *) CFLAGS="$CFLAGS -O3" ;; | ||
50 | esac | ||
51 | fi | ||
52 | |||
53 | if test -n "$PROFILEFLAG"; then | ||
54 | case " $CFLAGS " in | ||
55 | *[\ \ ]$PROFILEFLAG[\ \ ]*) ;; | ||
56 | *) CFLAGS="$PROFILEFLAG $CFLAGS" ;; | ||
57 | esac | ||
58 | fi | ||
59 | fi | ||
60 | changequote([,])dnl | ||
61 | |||
62 | AM_PROG_LIBTOOL | ||
63 | AC_HEADER_STDC | ||
64 | AC_PROG_MAKE_SET | ||
65 | |||
66 | AC_CHECK_FUNCS(gettimeofday) | ||
67 | AC_HEADER_TIME | ||
68 | |||
69 | AC_PATH_PROGS(EMACS, emacs xemacs, emacs) | ||
70 | |||
71 | top_srcdir_absolute=`cd $srcdir; pwd` | ||
72 | AC_SUBST(top_srcdir_absolute) | ||
73 | |||
74 | AM_PATH_GLIB(1.2.8,, | ||
75 | AC_MSG_ERROR(Test for GLIB failed. Download it from ftp://ftp.gtk.org/pub/gtk/v1.2/)) | ||
76 | |||
77 | dnl AC_CHECK_LIB(z, gzsetparams, */ | ||
78 | dnl AC_CHECK_HEADER(zlib.h,, */ | ||
79 | dnl AC_MSG_ERROR(ZLIB headers not found)), */ | ||
80 | dnl AC_MSG_ERROR(ZLIB library not found)) */ | ||
81 | |||
82 | AC_OUTPUT(Makefile | ||
83 | doc/Makefile | ||
84 | test/Makefile | ||
85 | djgpp/Makefile | ||
86 | xdelta-config | ||
87 | libedsio/Makefile | ||
88 | libedsio/edsio-comp, | ||
89 | |||
90 | chmod +x libedsio/edsio-comp xdelta-config | ||
91 | ) | ||