summaryrefslogtreecommitdiff
path: root/xdelta3/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xdelta3/Makefile.am')
-rw-r--r--xdelta3/Makefile.am54
1 files changed, 48 insertions, 6 deletions
diff --git a/xdelta3/Makefile.am b/xdelta3/Makefile.am
index 22b2721..fe0bd85 100644
--- a/xdelta3/Makefile.am
+++ b/xdelta3/Makefile.am
@@ -1,4 +1,7 @@
1bin_PROGRAMS = xdelta3 xdelta3regtest 1ACLOCAL_AMFLAGS = -I m4
2
3bin_PROGRAMS = xdelta3
4noinst_PROGRAMS = xdelta3regtest
2 5
3common_SOURCES = \ 6common_SOURCES = \
4 xdelta3-blkcache.h \ 7 xdelta3-blkcache.h \
@@ -32,7 +35,7 @@ xdelta3regtest_SOURCES = $(common_SOURCES) \
32 35
33WFLAGS = -Wall -Wshadow -fno-builtin -Wextra -Wsign-compare \ 36WFLAGS = -Wall -Wshadow -fno-builtin -Wextra -Wsign-compare \
34 -Wextra -Wno-unused-parameter 37 -Wextra -Wno-unused-parameter
35common_CFLAGS = $(WFLAGS) \ 38common_CFLAGS = \
36 -DGENERIC_ENCODE_TABLES=0 \ 39 -DGENERIC_ENCODE_TABLES=0 \
37 -DREGRESSION_TEST=1 \ 40 -DREGRESSION_TEST=1 \
38 -DSECONDARY_DJW=1 \ 41 -DSECONDARY_DJW=1 \
@@ -41,12 +44,23 @@ common_CFLAGS = $(WFLAGS) \
41 -DXD3_USE_LARGEFILE64=1 \ 44 -DXD3_USE_LARGEFILE64=1 \
42 -DXD3_MAIN=1 45 -DXD3_MAIN=1
43 46
44xdelta3_CFLAGS = $(common_CFLAGS) 47xdelta3_CFLAGS = $(WFLAGS) $(common_CFLAGS)
48
49xdelta3regtest_CXXFLAGS = $(WFLAGS) $(common_CFLAGS) -DNOT_MAIN=1 -DXD3_DEBUG=1
50xdelta3regtest_CFLAGS = $(WFLAGS) $(common_CFLAGS) -DNOT_MAIN=1 -DXD3_DEBUG=1
45 51
46xdelta3regtest_CXXFLAGS = $(common_CFLAGS) -DNOT_MAIN=1 -DXD3_DEBUG=1 52man1_MANS = xdelta3.1
47xdelta3regtest_CFLAGS = $(common_CFLAGS) -DNOT_MAIN=1 -DXD3_DEBUG=1
48 53
49EXTRA_DIST = \ 54EXTRA_DIST = \
55 draft-korn-vcdiff.txt \
56 examples/Makefile \
57 examples/README \
58 examples/checksum_test.cc \
59 examples/compare_test.c \
60 examples/encode_decode_test.c \
61 examples/small_page_test.c \
62 examples/speed_test.c \
63 examples/test.h \
50 examples/iOS/xdelta3-ios-test/xdelta3-ios-test.xcodeproj/project.pbxproj \ 64 examples/iOS/xdelta3-ios-test/xdelta3-ios-test.xcodeproj/project.pbxproj \
51 examples/iOS/xdelta3-ios-test/xdelta3-ios-test/Xd3iOSAppDelegate.h \ 65 examples/iOS/xdelta3-ios-test/xdelta3-ios-test/Xd3iOSAppDelegate.h \
52 examples/iOS/xdelta3-ios-test/xdelta3-ios-test/Xd3iOSAppDelegate.m \ 66 examples/iOS/xdelta3-ios-test/xdelta3-ios-test/Xd3iOSAppDelegate.m \
@@ -60,4 +74,32 @@ EXTRA_DIST = \
60 examples/iOS/xdelta3-ios-test/xdelta3-ios-test/file_v2.bin \ 74 examples/iOS/xdelta3-ios-test/xdelta3-ios-test/file_v2.bin \
61 examples/iOS/xdelta3-ios-test/xdelta3-ios-test/main.m \ 75 examples/iOS/xdelta3-ios-test/xdelta3-ios-test/main.m \
62 examples/iOS/xdelta3-ios-test/xdelta3-ios-test/xdelta3-ios-test-Info.plist \ 76 examples/iOS/xdelta3-ios-test/xdelta3-ios-test/xdelta3-ios-test-Info.plist \
63 examples/iOS/xdelta3-ios-test/xdelta3-ios-test/xdelta3-ios-test-Prefix.pch 77 examples/iOS/xdelta3-ios-test/xdelta3-ios-test/xdelta3-ios-test-Prefix.pch \
78 Makefile.mingw \
79 Makefile.orig \
80 testing/xdelta3-regtest.py \
81 testing/xdelta3-test.py \
82 xdelta3.1 \
83 xdelta3.i \
84 xdelta3.py \
85 xdelta3.vcproj \
86 xdelta3.wxi \
87 xdelta3.wxs \
88 xdelta3_pywrap.c
89
90BUILT_SOURCES = xdelta3_pywrap.c xdelta3.py
91
92xdelta3_pywrap.c xdelta3.py : xdelta3.i
93 $(SWIG) -python -o xdelta3_pywrap.c xdelta3.i
94
95# Note: This is probably incorrect, but makes it work in simple configurations
96# (like OS X) where the site-packages directory is not in the prefix directory.
97# See commented-out AM_CONDITIONAL in configure.ac, which is not working.
98pythondir = $(PYTHON_SITE_PKG)
99pyexecdir = $(PYTHON_SITE_PKG)
100
101python_PYTHON = xdelta3.py
102pyexec_LTLIBRARIES = _xdelta3.la
103_xdelta3_la_SOURCES = $(srcdir)/xdelta3_pywrap.c $(xdelta3_SOURCES)
104_xdelta3_la_CFLAGS = $(common_CFLAGS) -DNOT_MAIN=1 $(PYTHON_CPPFLAGS)
105_xdelta3_la_LDFLAGS = -module