summaryrefslogtreecommitdiff
path: root/xdelta3/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xdelta3/Makefile.am')
-rw-r--r--xdelta3/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/xdelta3/Makefile.am b/xdelta3/Makefile.am
index 3907351..9369100 100644
--- a/xdelta3/Makefile.am
+++ b/xdelta3/Makefile.am
@@ -38,7 +38,7 @@ xdelta3regtest_SOURCES = $(common_SOURCES) \
38# Note: for extra sanity checks, enable -Wconversion. Note there 38# Note: for extra sanity checks, enable -Wconversion. Note there
39# are a lot of false positives. 39# are a lot of false positives.
40WFLAGS = -Wall -Wshadow -fno-builtin -Wextra -Wsign-compare \ 40WFLAGS = -Wall -Wshadow -fno-builtin -Wextra -Wsign-compare \
41 -Wextra -Wno-unused-parameter -Wconversion 41 -Wextra -Wno-unused-parameter # -Wconversion
42 42
43 43
44C_WFLAGS = $(WFLAGS) -pedantic -std=c99 44C_WFLAGS = $(WFLAGS) -pedantic -std=c99
@@ -50,6 +50,7 @@ common_CFLAGS = \
50 -DSECONDARY_FGK=1 \ 50 -DSECONDARY_FGK=1 \
51 -DXD3_POSIX=1 \ 51 -DXD3_POSIX=1 \
52 -DXD3_USE_LARGEFILE64=1 \ 52 -DXD3_USE_LARGEFILE64=1 \
53 -DXD3_USE_LARGEWINDOW64=1 \
53 -DXD3_MAIN=1 54 -DXD3_MAIN=1
54 55
55if DEBUG_SYMBOLS 56if DEBUG_SYMBOLS
@@ -57,7 +58,7 @@ if DEBUG_SYMBOLS
57endif 58endif
58 59
59# For additional debugging, add -DXD3_DEBUG=1, 2, 3, ... 60# For additional debugging, add -DXD3_DEBUG=1, 2, 3, ...
60xdelta3_CFLAGS = $(C_WFLAGS) $(common_CFLAGS) -DXD3_DEBUG=0 61xdelta3_CFLAGS = $(C_WFLAGS) $(common_CFLAGS) -DXD3_DEBUG=3
61xdelta3_LDADD = -lm 62xdelta3_LDADD = -lm
62 63
63xdelta3decode_CFLAGS = \ 64xdelta3decode_CFLAGS = \