diff options
Diffstat (limited to 'xdelta3/Makefile.am')
-rw-r--r-- | xdelta3/Makefile.am | 29 |
1 files changed, 29 insertions, 0 deletions
diff --git a/xdelta3/Makefile.am b/xdelta3/Makefile.am new file mode 100644 index 0000000..e3dfbab --- /dev/null +++ b/xdelta3/Makefile.am | |||
@@ -0,0 +1,29 @@ | |||
1 | bin_PROGRAMS = xdelta3 | ||
2 | xdelta3_SOURCES = \ | ||
3 | xdelta3-blkcache.h \ | ||
4 | xdelta3-cfgs.h \ | ||
5 | xdelta3-decode.h \ | ||
6 | xdelta3-djw.h \ | ||
7 | xdelta3-fgk.h \ | ||
8 | xdelta3-hash.h \ | ||
9 | xdelta3-list.h \ | ||
10 | xdelta3-main.h \ | ||
11 | xdelta3-merge.h \ | ||
12 | xdelta3-python.h \ | ||
13 | xdelta3-second.h \ | ||
14 | xdelta3-test.h \ | ||
15 | xdelta3.c \ | ||
16 | xdelta3.h | ||
17 | |||
18 | WFLAGS = -Wall -Wshadow -fno-builtin -Wextra -Wsign-compare \ | ||
19 | -Wextra -Wno-unused-parameter | ||
20 | # -Wconversion | ||
21 | xdelta3_CFLAGS = $(WFLAGS) \ | ||
22 | -DGENERIC_ENCODE_TABLES=0 \ | ||
23 | -DREGRESSION_TEST=1 \ | ||
24 | -DSECONDARY_DJW=1 \ | ||
25 | -DSECONDARY_FGK=1 \ | ||
26 | -DXD3_DEBUG=0 \ | ||
27 | -DXD3_MAIN=1 \ | ||
28 | -DXD3_POSIX=1 \ | ||
29 | -DXD3_USE_LARGEFILE64=1 | ||