summaryrefslogtreecommitdiff
path: root/xdelta3/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'xdelta3/setup.py')
-rwxr-xr-xxdelta3/setup.py33
1 files changed, 33 insertions, 0 deletions
diff --git a/xdelta3/setup.py b/xdelta3/setup.py
new file mode 100755
index 0000000..9d717e8
--- /dev/null
+++ b/xdelta3/setup.py
@@ -0,0 +1,33 @@
1# xdelta 3 - delta compression tools and library
2# Copyright (C) 2004 and onward. Joshua P. MacDonald
3#
4# This program is free software; you can redistribute it and/or modify
5# it under the terms of the GNU General Public License as published by
6# the Free Software Foundation; either version 2 of the License, or
7# (at your option) any later version.
8#
9# This program is distributed in the hope that it will be useful,
10# but WITHOUT ANY WARRANTY; without even the implied warranty of
11# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
12# GNU General Public License for more details.
13#
14# You should have received a copy of the GNU General Public License
15# along with this program; if not, write to the Free Software
16# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
17#
18#
19from distutils.core import setup, Extension
20
21xdelta3_ext = Extension('xdelta3',
22 ['xdelta3.c'],
23 define_macros = [('PYTHON_MODULE',1),
24 ('XD3_POSIX',1),
25 ('REGRESSION_TEST',1),
26 ('XD3_DEBUG',1),
27 ('EXTCOMP',1),
28 ('VCDIFF_TOOLS',1),
29 ('XD3_USE_LARGEFILE64',1)])
30
31setup(name='xdelta3',
32 version='pre',
33 ext_modules=[xdelta3_ext])