summaryrefslogtreecommitdiff
path: root/xdelta3/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'xdelta3/setup.py')
-rw-r--r--xdelta3/setup.py14
1 files changed, 5 insertions, 9 deletions
diff --git a/xdelta3/setup.py b/xdelta3/setup.py
index f89aba7..abc902d 100644
--- a/xdelta3/setup.py
+++ b/xdelta3/setup.py
@@ -22,14 +22,8 @@ from distutils.util import get_platform
22# External compression support works on Windows/Cygwin, but not from 22# External compression support works on Windows/Cygwin, but not from
23# within the Python module. It's something to do with fork() and 23# within the Python module. It's something to do with fork() and
24# exec() support. 24# exec() support.
25platform = get_platform() 25#platform = get_platform()
26is_cygwin = platform.startswith('cygwin') 26#is_cygwin = platform.startswith('cygwin')
27extcomp = 1
28
29if is_cygwin:
30 print 'Note: not compiling external compression support for Python/Cygwin'
31 extcomp = 0
32#end
33 27
34xdelta3_ext = Extension('xdelta3main', 28xdelta3_ext = Extension('xdelta3main',
35 ['xdelta3.c'], 29 ['xdelta3.c'],
@@ -41,7 +35,9 @@ xdelta3_ext = Extension('xdelta3main',
41 ('XD3_POSIX',1), 35 ('XD3_POSIX',1),
42 ('XD3_USE_LARGEFILE64',1), 36 ('XD3_USE_LARGEFILE64',1),
43 37
44 ('EXTERNAL_COMPRESSION',extcomp), 38 # the fork/exec stuff doesn't
39 # work inside python.
40 ('EXTERNAL_COMPRESSION',0),
45 41
46 ('REGRESSION_TEST',0), 42 ('REGRESSION_TEST',0),
47 ('SECONDARY_FGK',0), 43 ('SECONDARY_FGK',0),