summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaakko Keränen <jaakko.keranen@iki.fi>2020-07-31 08:01:28 +0300
committerJaakko Keränen <jaakko.keranen@iki.fi>2020-07-31 08:01:28 +0300
commit07022bc768a8f23cf051dc6a58e85195886478d5 (patch)
treec0c97d45094fe3dde584136955ac3d6b813528ee /CMakeLists.txt
parent01e80caec8220c1d57d4e2ef4eb9c99538842429 (diff)
Use the full Symbola font; don't embed resources
The fonts are too large to embed comfortably.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 42e70ef8..de97bf0a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,6 +14,8 @@ pkg_check_modules (SDL2 REQUIRED sdl2)
14 14
15# Embedded resources are written to a generated source file. 15# Embedded resources are written to a generated source file.
16message (STATUS "Preparing embedded resources...") 16message (STATUS "Preparing embedded resources...")
17# Fonts are too large to comfortably embed as a C source.
18set (EMBED_IN_EXECUTABLE OFF CACHE BOOL "Embed resources inside the executable")
17set (EMBED_RESOURCES 19set (EMBED_RESOURCES
18 res/SourceSansPro-Regular.ttf 20 res/SourceSansPro-Regular.ttf
19 res/FiraSans-Regular.ttf 21 res/FiraSans-Regular.ttf
@@ -21,15 +23,19 @@ set (EMBED_RESOURCES
21 res/FiraSans-Italic.ttf 23 res/FiraSans-Italic.ttf
22 res/FiraMono-Regular.ttf 24 res/FiraMono-Regular.ttf
23 res/NotoEmoji-Regular.ttf 25 res/NotoEmoji-Regular.ttf
24 res/SymbolaSubset.ttf 26 res/Symbola.ttf
25) 27)
26# if (UNIX AND NOT APPLE) 28# if (UNIX AND NOT APPLE)
27# list (APPEND EMBED_RESOURCES res/appicon-64.png) 29# list (APPEND EMBED_RESOURCES res/appicon-64.png)
28# endif () 30# endif ()
29embed_make (${EMBED_RESOURCES}) 31embed_make (${EMBED_RESOURCES})
30 32
33set (EMB_BIN ${CMAKE_CURRENT_BINARY_DIR}/resources.bin)
34set_source_files_properties (${EMB_BIN} PROPERTIES MACOSX_PACKAGE_LOCATION Resources)
35
31# Source files. 36# Source files.
32set (SOURCES 37set (SOURCES
38 ${CMAKE_CURRENT_BINARY_DIR}/resources.bin
33 ${CMAKE_CURRENT_BINARY_DIR}/embedded.c 39 ${CMAKE_CURRENT_BINARY_DIR}/embedded.c
34 ${CMAKE_CURRENT_BINARY_DIR}/embedded.h 40 ${CMAKE_CURRENT_BINARY_DIR}/embedded.h
35 src/main.c 41 src/main.c