summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaakko Keränen <jaakko.keranen@iki.fi>2021-01-18 19:19:47 +0200
committerJaakko Keränen <jaakko.keranen@iki.fi>2021-01-18 19:19:47 +0200
commit1ac1db7f0b508e6219dce4aa2fbd2c5515472506 (patch)
tree6b076cea341655240fa2d048ad76e35a30786b14 /CMakeLists.txt
parent7e393a4fda482d01252bd1a6e84ca8149bcc278e (diff)
Renamed ".binary" files
Use the .lgr extension for Lagrange binary files.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e27956cd..e8ee03b5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -86,7 +86,7 @@ if (UNIX AND NOT APPLE)
86endif () 86endif ()
87embed_make (${EMBED_RESOURCES}) 87embed_make (${EMBED_RESOURCES})
88 88
89set (EMB_BIN ${CMAKE_CURRENT_BINARY_DIR}/resources.binary) 89set (EMB_BIN ${CMAKE_CURRENT_BINARY_DIR}/resources.lgr)
90set_source_files_properties (${EMB_BIN} PROPERTIES MACOSX_PACKAGE_LOCATION Resources) 90set_source_files_properties (${EMB_BIN} PROPERTIES MACOSX_PACKAGE_LOCATION Resources)
91 91
92# Source files. 92# Source files.
@@ -177,7 +177,7 @@ set (SOURCES
177 res/about/help.gmi 177 res/about/help.gmi
178 res/about/lagrange.gmi 178 res/about/lagrange.gmi
179 res/about/version.gmi 179 res/about/version.gmi
180 ${CMAKE_CURRENT_BINARY_DIR}/resources.binary 180 ${CMAKE_CURRENT_BINARY_DIR}/resources.lgr
181 ${CMAKE_CURRENT_BINARY_DIR}/embedded.c 181 ${CMAKE_CURRENT_BINARY_DIR}/embedded.c
182 ${CMAKE_CURRENT_BINARY_DIR}/embedded.h 182 ${CMAKE_CURRENT_BINARY_DIR}/embedded.h
183) 183)
@@ -301,7 +301,7 @@ MimeType=x-scheme-handler/gemini;x-scheme-handler/gopher
301 ) 301 )
302 if (NOT ENABLE_RESOURCE_EMBED) 302 if (NOT ENABLE_RESOURCE_EMBED)
303 target_compile_definitions (app PUBLIC 303 target_compile_definitions (app PUBLIC
304 LAGRANGE_EMB_BIN="${CMAKE_INSTALL_PREFIX}/share/lagrange/resources.binary") 304 LAGRANGE_EMB_BIN="${CMAKE_INSTALL_PREFIX}/share/lagrange/resources.lgr")
305 install (FILES ${EMB_BIN} DESTINATION share/lagrange) 305 install (FILES ${EMB_BIN} DESTINATION share/lagrange)
306 endif () 306 endif ()
307endif () 307endif ()