summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaakko Keränen <jaakko.keranen@iki.fi>2021-02-18 21:41:46 +0200
committerJaakko Keränen <jaakko.keranen@iki.fi>2021-02-18 21:41:46 +0200
commit3d0f88fcf9a262680c19bd5c44e407a02c409dcf (patch)
treecfd39dbe14683e5c9fa4b24805a49c3301a10f3f /CMakeLists.txt
parent0962147cc8fa92e5a79458bf1270ded51c9a4433 (diff)
iOS: Working on touch event handling
Handle finger down, motion, and up events to implement basic taps, long presses, and inertia scrolling. Much finetuning still to be done, and certain widgets like input fields and scrollbars need a direct drag mode (they were working fine via the "mouse" events already).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ccdb1cc1..216ccfc0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -150,6 +150,8 @@ set (SOURCES
150 src/ui/sidebarwidget.h 150 src/ui/sidebarwidget.h
151 src/ui/text.c 151 src/ui/text.c
152 src/ui/text.h 152 src/ui/text.h
153 src/ui/touch.c
154 src/ui/touch.h
153 src/ui/util.c 155 src/ui/util.c
154 src/ui/util.h 156 src/ui/util.h
155 src/ui/visbuf.c 157 src/ui/visbuf.c
@@ -230,6 +232,9 @@ target_link_libraries (app PUBLIC ${SDL2_LDFLAGS})
230if (APPLE) 232if (APPLE)
231 if (IOS) 233 if (IOS)
232 target_link_libraries (app PUBLIC "-framework UIKit") 234 target_link_libraries (app PUBLIC "-framework UIKit")
235 set_target_properties (app PROPERTIES
236 XCODE_ATTRIBUTE_TARGETED_DEVICE_FAMILY 2
237 )
233 else () 238 else ()
234 target_link_libraries (app PUBLIC "-framework AppKit") 239 target_link_libraries (app PUBLIC "-framework AppKit")
235 endif () 240 endif ()