summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaakko Keränen <jaakko.keranen@iki.fi>2020-08-09 13:21:29 +0300
committerJaakko Keränen <jaakko.keranen@iki.fi>2020-08-09 13:21:29 +0300
commit46a5d265ad180fc9f79c4d0adddfc21101009a93 (patch)
tree278c0f3c044483e9c5e8cb8f0bd20a7b797bc49a /CMakeLists.txt
parent67b430feae483f44078dd6f5ff96771073e746db (diff)
Deploy resources.bin if in use
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1f0014bd..3a78f16e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -138,6 +138,9 @@ endif ()
138# Deployment. 138# Deployment.
139if (MSYS) 139if (MSYS)
140 install (TARGETS app DESTINATION .) 140 install (TARGETS app DESTINATION .)
141 if (NOT EMBED_IN_EXECUTABLE)
142 install (FILES ${EMB_BIN} DESTINATION .)
143 endif ()
141 install (PROGRAMS 144 install (PROGRAMS
142 ${SDL2_LIBDIR}/SDL2.dll 145 ${SDL2_LIBDIR}/SDL2.dll
143 $<TARGET_FILE:the_Foundation::the_Foundation> 146 $<TARGET_FILE:the_Foundation::the_Foundation>
@@ -158,9 +161,12 @@ Type=Application
158Icon=fi.skyjake.lagrange") 161Icon=fi.skyjake.lagrange")
159 install (TARGETS app DESTINATION bin) 162 install (TARGETS app DESTINATION bin)
160 install (FILES ${desktop} DESTINATION share/applications) 163 install (FILES ${desktop} DESTINATION share/applications)
161 install (FILES res/lagrange-256.png 164 install (FILES res/lagrange-256.png
162 DESTINATION share/icons/hicolor/256x256/apps 165 DESTINATION share/icons/hicolor/256x256/apps
163 RENAME fi.skyjake.lagrange.png 166 RENAME fi.skyjake.lagrange.png
164 ) 167 )
168 if (NOT EMBED_IN_EXECUTABLE)
169 install (FILES ${EMB_BIN} DESTINATION share/lagrange)
170 endif ()
165endif () 171endif ()
166 172