summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaakko Keränen <jaakko.keranen@iki.fi>2020-09-08 18:27:44 +0300
committerJaakko Keränen <jaakko.keranen@iki.fi>2020-09-08 18:27:44 +0300
commit6a4ca42f7c053c2c53d901885a50398de04af38f (patch)
tree60ae16bf66b63ca902b5e24543f5ecbefc9281a3 /CMakeLists.txt
parent81ce49690631e2f55ed029e161ae9a271b24f407 (diff)
Cleanup
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 99aeeae5..43638dfb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,15 +13,15 @@ option (ENABLE_RESOURCE_EMBED "Embed resources inside the executable" OFF)
13 13
14include (BuildType.cmake) 14include (BuildType.cmake)
15include (Embed.cmake) 15include (Embed.cmake)
16if (EXISTS ${CMAKE_SOURCE_DIR}/lib/the_Foundation) 16if (NOT EXISTS ${CMAKE_SOURCE_DIR}/lib/the_Foundation)
17 set (TFDN_STATIC_LIBRARY ON CACHE BOOL "Shared library not needed") 17 find_package (the_Foundation REQUIRED)
18 set (TFDN_ENABLE_INSTALL OFF CACHE BOOL "Library install not needed") 18else ()
19 set (TFDN_ENABLE_TESTS OFF CACHE BOOL "Library tests not needed") 19 set (TFDN_STATIC_LIBRARY ON CACHE BOOL "")
20 set (TFDN_ENABLE_WEBREQUEST OFF CACHE BOOL "libcurl not needed") 20 set (TFDN_ENABLE_INSTALL OFF CACHE BOOL "")
21 set (TFDN_ENABLE_TESTS OFF CACHE BOOL "")
22 set (TFDN_ENABLE_WEBREQUEST OFF CACHE BOOL "")
21 add_subdirectory (lib/the_Foundation) 23 add_subdirectory (lib/the_Foundation)
22 add_library (the_Foundation::the_Foundation ALIAS the_Foundation) 24 add_library (the_Foundation::the_Foundation ALIAS the_Foundation)
23else ()
24 find_package (the_Foundation REQUIRED)
25endif () 25endif ()
26find_package (PkgConfig REQUIRED) 26find_package (PkgConfig REQUIRED)
27pkg_check_modules (SDL2 REQUIRED sdl2) 27pkg_check_modules (SDL2 REQUIRED sdl2)