summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaakko Keränen <jaakko.keranen@iki.fi>2021-03-29 11:06:09 +0300
committerJaakko Keränen <jaakko.keranen@iki.fi>2021-03-29 11:06:09 +0300
commit6dc49edb93b6e9099a97b502fde246619bbc49c8 (patch)
treed7f832467f00668ce9abe7f54ba8af71186e0e4a /CMakeLists.txt
parentfb38f92c3a5c29c568575df87f0c29e777ebd969 (diff)
parentd2a1a0ac7f1423d91229a83b299b3901e30ed28f (diff)
Merge branch 'dev' of codeberg.org:skyjake/lagrange into dev
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 75883966..9fe62ba4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -324,6 +324,9 @@ endif ()
324if (UNIX) 324if (UNIX)
325 target_link_libraries (app PUBLIC m) 325 target_link_libraries (app PUBLIC m)
326endif () 326endif ()
327if (HAIKU)
328 target_link_libraries (app PUBLIC m network bsd)
329endif ()
327 330
328# Deployment. 331# Deployment.
329if (MSYS) 332if (MSYS)
@@ -342,6 +345,13 @@ if (MSYS)
342 if (INSTALL_THE_FOUNDATION) 345 if (INSTALL_THE_FOUNDATION)
343 install (PROGRAMS $<TARGET_FILE:the_Foundation::the_Foundation> DESTINATION .) 346 install (PROGRAMS $<TARGET_FILE:the_Foundation::the_Foundation> DESTINATION .)
344 endif () 347 endif ()
348elseif (HAIKU)
349 install (TARGETS app DESTINATION .)
350 if (NOT ENABLE_RESOURCE_EMBED)
351 target_compile_definitions (app PUBLIC
352 LAGRANGE_EMB_BIN="${CMAKE_INSTALL_PREFIX}/resources.lgr")
353 install (FILES ${EMB_BIN} DESTINATION .)
354 endif ()
345elseif (UNIX AND NOT APPLE) 355elseif (UNIX AND NOT APPLE)
346 set_target_properties (app PROPERTIES 356 set_target_properties (app PROPERTIES
347 INSTALL_RPATH_USE_LINK_PATH YES 357 INSTALL_RPATH_USE_LINK_PATH YES