summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaakko Keränen <jaakko.keranen@iki.fi>2021-12-06 09:20:30 +0200
committerJaakko Keränen <jaakko.keranen@iki.fi>2021-12-06 09:20:30 +0200
commit7e69aeb1a8157eb34981a21930f108a0a7efad9c (patch)
tree68ef6b801d04a2c48c6dbbc5b3fea085c354fea1 /CMakeLists.txt
parentff316e540269a34214d298249190db8891b2d885 (diff)
iOS: Platform-specific release notes and Help
TODO: Help needs rewriting from a mobile perspective.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 12 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 71940aa4..a6943885 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,11 +66,8 @@ include (Depends.cmake)
66message (STATUS "Preparing resources...") 66message (STATUS "Preparing resources...")
67set (RESOURCES 67set (RESOURCES
68 res/about/about.gmi 68 res/about/about.gmi
69 res/about/help.gmi
70 res/about/lagrange.gmi 69 res/about/lagrange.gmi
71 res/about/license.gmi 70 res/about/license.gmi
72 res/about/version.gmi
73 res/arg-help.txt
74 res/lang/cs.bin 71 res/lang/cs.bin
75 res/lang/de.bin 72 res/lang/de.bin
76 res/lang/en.bin 73 res/lang/en.bin
@@ -98,6 +95,18 @@ set (RESOURCES
98) 95)
99file (GLOB FONTS RELATIVE ${CMAKE_SOURCE_DIR} res/fonts/*) 96file (GLOB FONTS RELATIVE ${CMAKE_SOURCE_DIR} res/fonts/*)
100list (APPEND RESOURCES ${FONTS}) 97list (APPEND RESOURCES ${FONTS})
98if (IOS)
99 list (APPEND RESOURCES
100 res/about/ios-help.gmi
101 res/about/ios-version.gmi
102 )
103else ()
104 list (APPEND RESOURCES
105 res/about/help.gmi
106 res/about/version.gmi
107 res/arg-help.txt
108 )
109endif ()
101if ((UNIX AND NOT APPLE) OR MSYS) 110if ((UNIX AND NOT APPLE) OR MSYS)
102 list (APPEND RESOURCES res/lagrange-64.png) 111 list (APPEND RESOURCES res/lagrange-64.png)
103endif () 112endif ()