summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaakko Keränen <jaakko.keranen@iki.fi>2020-09-20 14:25:18 +0300
committerJaakko Keränen <jaakko.keranen@iki.fi>2020-09-20 14:25:18 +0300
commit8adc74e242ee6305d4a9016b1e6f31036b742067 (patch)
tree3910595ad65f653e558b4b6b3846a6844bb6f1bc /CMakeLists.txt
parent1323d511ad8f0c2697a8a933c721087197224072 (diff)
macOS: No fixed deployment target
Let the user decide.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7bac42be..23ba80f8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,7 +17,6 @@
17# - `cat` is relied upon for merging all the resource files together. 17# - `cat` is relied upon for merging all the resource files together.
18 18
19cmake_minimum_required (VERSION 3.9) 19cmake_minimum_required (VERSION 3.9)
20set (CMAKE_OSX_DEPLOYMENT_TARGET 10.14)
21 20
22project (Lagrange 21project (Lagrange
23 VERSION 0.3.0 22 VERSION 0.3.0
@@ -189,8 +188,10 @@ if (APPLE)
189 else () 188 else ()
190 target_link_libraries (app PUBLIC "-framework AppKit") 189 target_link_libraries (app PUBLIC "-framework AppKit")
191 endif () 190 endif ()
192 target_compile_options (app PUBLIC -mmacosx-version-min=10.14) 191 if (CMAKE_OSX_DEPLOYMENT_TARGET)
193 target_link_options (app PUBLIC -mmacosx-version-min=10.14) 192 target_compile_options (app PUBLIC -mmacosx-version-min=${CMAKE_OSX_DEPLOYMENT_TARGET})
193 target_link_options (app PUBLIC -mmacosx-version-min=${CMAKE_OSX_DEPLOYMENT_TARGET})
194 endif ()
194 set_target_properties (app PROPERTIES 195 set_target_properties (app PROPERTIES
195 OUTPUT_NAME "Lagrange" 196 OUTPUT_NAME "Lagrange"
196 BUILD_RPATH ${SDL2_LIBRARY_DIRS} 197 BUILD_RPATH ${SDL2_LIBRARY_DIRS}