summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaakko Keränen <jaakko.keranen@iki.fi>2020-09-18 12:31:10 +0300
committerJaakko Keränen <jaakko.keranen@iki.fi>2020-09-18 12:31:10 +0300
commit9e40dca30b0c1e61b0ded4725b7db4f225684e2a (patch)
treeae9b7cd2dd0e8ea1bed43f0cdddf749c312b4c25 /CMakeLists.txt
parent24769923618c19e7c4634f6dbdcc7ed087918a9c (diff)
Added some build notes
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 39b5e63a..1f6c6064 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,3 +1,21 @@
1# Lagrange - A Beautiful Gemini Client
2# Copyright: 2020 Jaakko Keränen <jaakko.keranen@iki.fi>
3#
4# Notes:
5# - Required dependencies: SDL 2, OpenSSL 1.1.1, libpcre,
6# GNU libunistring, zlib.
7# - the_Foundation is built as a static library from 'lib/the_Foundation',
8# if it exists in that location. The Git repository has it as a submodule.
9# - Windows builds require MSYS2. In theory, Clang could be set up on
10# Windows for compiling everything, but the_Foundation still lacks
11# native Win32 implementations for the Socket and Process classes.
12# - Windows builds should use the SDL 2 library precompiled for native
13# Windows (MSVC variant) instead the version from MSYS2 (get it from
14# https://libsdl.org/). To make configuration easier, consider writing
15# for your personal use a pkg-config sdl2.pc file that uses the Windows
16# version of the library.
17# - `cat` is relied upon for merging all the resource files together.
18
1cmake_minimum_required (VERSION 3.9) 19cmake_minimum_required (VERSION 3.9)
2set (CMAKE_OSX_DEPLOYMENT_TARGET 10.14) 20set (CMAKE_OSX_DEPLOYMENT_TARGET 10.14)
3 21