summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaakko Keränen <jaakko.keranen@iki.fi>2021-12-25 15:37:43 +0200
committerJaakko Keränen <jaakko.keranen@iki.fi>2021-12-25 15:37:43 +0200
commitaa2ef95dc93c2cd2c4f9163836111333a12db217 (patch)
treeb1d0c022456764f7de1aa12e31cc62af4a07fde9 /CMakeLists.txt
parentaf356ea33f54e81b35ca24274cc33e6fc295e019 (diff)
iOS: Default to idle sleep enabled
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 134f9e8f..a5b76eb4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -34,6 +34,10 @@ set (DEFAULT_RESIZE_DRAW ON)
34if (HAIKU) 34if (HAIKU)
35 set (DEFAULT_RESIZE_DRAW OFF) 35 set (DEFAULT_RESIZE_DRAW OFF)
36endif () 36endif ()
37set (DEFAULT_IDLE_SLEEP OFF)
38if (IOS)
39 set (DEFAULT_IDLE_SLEEP ON)
40endif ()
37 41
38# Build configuration. 42# Build configuration.
39option (ENABLE_CUSTOM_FRAME "Draw a custom window frame (Windows)" OFF) 43option (ENABLE_CUSTOM_FRAME "Draw a custom window frame (Windows)" OFF)
@@ -42,7 +46,7 @@ option (ENABLE_FRIBIDI "Use the GNU FriBidi library for bidirectional t
42option (ENABLE_FRIBIDI_BUILD "Build the GNU FriBidi library (if OFF, try pkg-config)" OFF) 46option (ENABLE_FRIBIDI_BUILD "Build the GNU FriBidi library (if OFF, try pkg-config)" OFF)
43option (ENABLE_HARFBUZZ "Use the HarfBuzz library to shape text" ON) 47option (ENABLE_HARFBUZZ "Use the HarfBuzz library to shape text" ON)
44option (ENABLE_HARFBUZZ_MINIMAL "Build the HarfBuzz library with minimal dependencies (if OFF, try pkg-config)" OFF) 48option (ENABLE_HARFBUZZ_MINIMAL "Build the HarfBuzz library with minimal dependencies (if OFF, try pkg-config)" OFF)
45option (ENABLE_IDLE_SLEEP "While idle, sleep in the main thread instead of waiting for events" OFF) 49option (ENABLE_IDLE_SLEEP "While idle, sleep in the main thread instead of waiting for events" ${DEFAULT_IDLE_SLEEP})
46option (ENABLE_IPC "Use IPC to communicate between running instances" ON) 50option (ENABLE_IPC "Use IPC to communicate between running instances" ON)
47option (ENABLE_KERNING "Enable kerning in font renderer (slower)" ON) 51option (ENABLE_KERNING "Enable kerning in font renderer (slower)" ON)
48option (ENABLE_MAC_MENUS "Use native context menus (macOS)" ON) 52option (ENABLE_MAC_MENUS "Use native context menus (macOS)" ON)