diff options
author | Jaakko Keränen <jaakko.keranen@iki.fi> | 2021-12-05 10:25:44 +0200 |
---|---|---|
committer | Jaakko Keränen <jaakko.keranen@iki.fi> | 2021-12-05 10:25:44 +0200 |
commit | be8fcebadb4a12844dd367d1f7da03bbe920ea0a (patch) | |
tree | 1e1b0614b660adfc593052aa262dc97c9ac64949 /CMakeLists.txt | |
parent | 6b4d15c83232d3af564157afdc32dfb5573c2aef (diff) |
iOS: Custom editor font and adjusted positioning
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 8 |
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 4200c7c5..2d11e43e 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -104,6 +104,12 @@ endif () | |||
104 | set (EMB_BIN ${CMAKE_CURRENT_BINARY_DIR}/resources.lgr) | 104 | set (EMB_BIN ${CMAKE_CURRENT_BINARY_DIR}/resources.lgr) |
105 | make_resources (${EMB_BIN} ${RESOURCES}) | 105 | make_resources (${EMB_BIN} ${RESOURCES}) |
106 | set_source_files_properties (${EMB_BIN} PROPERTIES MACOSX_PACKAGE_LOCATION Resources) | 106 | set_source_files_properties (${EMB_BIN} PROPERTIES MACOSX_PACKAGE_LOCATION Resources) |
107 | if (IOS) | ||
108 | set (EMB_FONTS res/fonts/SourceSans3-Regular.ttf) | ||
109 | set_source_files_properties (${EMB_FONTS} | ||
110 | PROPERTIES MACOSX_PACKAGE_LOCATION Resources | ||
111 | ) | ||
112 | endif () | ||
107 | 113 | ||
108 | # Source files. | 114 | # Source files. |
109 | set (SOURCES | 115 | set (SOURCES |
@@ -287,7 +293,7 @@ else () | |||
287 | endif () | 293 | endif () |
288 | 294 | ||
289 | # Target. | 295 | # Target. |
290 | add_executable (app ${SOURCES} ${RESOURCES}) | 296 | add_executable (app ${SOURCES} ${RESOURCES} ${EMB_FONTS}) |
291 | set_property (TARGET app PROPERTY C_STANDARD 11) | 297 | set_property (TARGET app PROPERTY C_STANDARD 11) |
292 | if (TARGET ext-deps) | 298 | if (TARGET ext-deps) |
293 | add_dependencies (app ext-deps) | 299 | add_dependencies (app ext-deps) |