summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaakko Keränen <jaakko.keranen@iki.fi>2021-12-05 10:25:44 +0200
committerJaakko Keränen <jaakko.keranen@iki.fi>2021-12-05 10:25:44 +0200
commitbe8fcebadb4a12844dd367d1f7da03bbe920ea0a (patch)
tree1e1b0614b660adfc593052aa262dc97c9ac64949 /CMakeLists.txt
parent6b4d15c83232d3af564157afdc32dfb5573c2aef (diff)
iOS: Custom editor font and adjusted positioning
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4200c7c5..2d11e43e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -104,6 +104,12 @@ endif ()
104set (EMB_BIN ${CMAKE_CURRENT_BINARY_DIR}/resources.lgr) 104set (EMB_BIN ${CMAKE_CURRENT_BINARY_DIR}/resources.lgr)
105make_resources (${EMB_BIN} ${RESOURCES}) 105make_resources (${EMB_BIN} ${RESOURCES})
106set_source_files_properties (${EMB_BIN} PROPERTIES MACOSX_PACKAGE_LOCATION Resources) 106set_source_files_properties (${EMB_BIN} PROPERTIES MACOSX_PACKAGE_LOCATION Resources)
107if (IOS)
108 set (EMB_FONTS res/fonts/SourceSans3-Regular.ttf)
109 set_source_files_properties (${EMB_FONTS}
110 PROPERTIES MACOSX_PACKAGE_LOCATION Resources
111 )
112endif ()
107 113
108# Source files. 114# Source files.
109set (SOURCES 115set (SOURCES
@@ -287,7 +293,7 @@ else ()
287endif () 293endif ()
288 294
289# Target. 295# Target.
290add_executable (app ${SOURCES} ${RESOURCES}) 296add_executable (app ${SOURCES} ${RESOURCES} ${EMB_FONTS})
291set_property (TARGET app PROPERTY C_STANDARD 11) 297set_property (TARGET app PROPERTY C_STANDARD 11)
292if (TARGET ext-deps) 298if (TARGET ext-deps)
293 add_dependencies (app ext-deps) 299 add_dependencies (app ext-deps)