summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaakko Keränen <jaakko.keranen@iki.fi>2020-09-30 14:54:27 +0300
committerJaakko Keränen <jaakko.keranen@iki.fi>2020-09-30 14:55:12 +0300
commitd27c0261cbbf77396e70c46c5fdb3745a85e48c0 (patch)
tree4802b3b2a537e4e278424fb722e79170f3f35933 /CMakeLists.txt
parent3228d8104af43366ae80713594c5998791e09600 (diff)
Windows: Use the system UI scaling factor
Check for system UI scaling factor via Direct2D DPI values.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0a54a9eb..1e323d47 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -212,6 +212,9 @@ if (APPLE)
212 MACOSX_BUNDLE_COPYRIGHT "© ${COPYRIGHT_YEAR} Jaakko Keränen" 212 MACOSX_BUNDLE_COPYRIGHT "© ${COPYRIGHT_YEAR} Jaakko Keränen"
213 ) 213 )
214endif () 214endif ()
215if (MSYS)
216 target_link_libraries (app PUBLIC d2d1 uuid) # querying DPI
217endif ()
215if (UNIX) 218if (UNIX)
216 target_link_libraries (app PUBLIC m) 219 target_link_libraries (app PUBLIC m)
217endif () 220endif ()