diff options
author | Jaakko Keränen <jaakko.keranen@iki.fi> | 2021-11-14 22:20:26 +0200 |
---|---|---|
committer | Jaakko Keränen <jaakko.keranen@iki.fi> | 2021-11-14 22:20:26 +0200 |
commit | d368b2b41bf45b3a3a8a2ab5f8b61fb3dac5b7ea (patch) | |
tree | f1390e1fd47f044ba5a94069756875cc110c765a /CMakeLists.txt | |
parent | 7de74d5ed0b1424defcbe41342f6c544f0a813a2 (diff) |
Localized language names in Preferences
Each dropdown item now uses its own language. This avoids the need to translate all language names to every language, and also helps the user to find the language(s) they understand.
The name strings are incorporated as C11 u8"" string literals, which hopefully won't cause compatibility issues as the_Foundation already requires C11.
Note that the Translation dialog retains the localized language labels because the user may not speak the source language, so they need to see it in their own language.
IssueID #391
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 1 |
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 08b4c053..314505c5 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -281,6 +281,7 @@ endif () | |||
281 | 281 | ||
282 | # Target. | 282 | # Target. |
283 | add_executable (app ${SOURCES} ${RESOURCES}) | 283 | add_executable (app ${SOURCES} ${RESOURCES}) |
284 | set_property (TARGET app PROPERTY C_STANDARD 11) | ||
284 | if (TARGET ext-deps) | 285 | if (TARGET ext-deps) |
285 | add_dependencies (app ext-deps) | 286 | add_dependencies (app ext-deps) |
286 | endif () | 287 | endif () |