summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaakko Keränen <jaakko.keranen@iki.fi>2020-09-18 10:34:49 +0300
committerJaakko Keränen <jaakko.keranen@iki.fi>2020-09-18 10:34:49 +0300
commitd45b2fd2da5183610aef250becd1d32dab46dcae (patch)
tree64e1eb635cc26bb1891c27fa9c5e5134cf13941d /CMakeLists.txt
parent210d06a75c300593fb8353d48e9a3cb84fdcb4d1 (diff)
Windows: Use a batch file to open URLs in browser
Opening via urlopen.bat works under MSYS bash as well. The .bat file is also a place where the user can customize which browser to open.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 53b3561f..39b5e63a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -189,7 +189,11 @@ if (MSYS)
189 if (NOT ENABLE_RESOURCE_EMBED) 189 if (NOT ENABLE_RESOURCE_EMBED)
190 install (FILES ${EMB_BIN} DESTINATION .) 190 install (FILES ${EMB_BIN} DESTINATION .)
191 endif () 191 endif ()
192 install (PROGRAMS ${SDL2_LIBDIR}/SDL2.dll DESTINATION .) 192 install (PROGRAMS
193 ${SDL2_LIBDIR}/SDL2.dll
194 res/urlopen.bat
195 DESTINATION .
196 )
193 if (INSTALL_THE_FOUNDATION) 197 if (INSTALL_THE_FOUNDATION)
194 install (PROGRAMS $<TARGET_FILE:the_Foundation::the_Foundation> DESTINATION .) 198 install (PROGRAMS $<TARGET_FILE:the_Foundation::the_Foundation> DESTINATION .)
195 endif () 199 endif ()