diff options
author | Jaakko Keränen <jaakko.keranen@iki.fi> | 2022-01-01 15:37:32 +0200 |
---|---|---|
committer | Jaakko Keränen <jaakko.keranen@iki.fi> | 2022-01-01 15:37:32 +0200 |
commit | ffdbd9444fc436c6f85412da45fa76d6147044f3 (patch) | |
tree | 3d2586628441add83ab52310a83f90a1d97ebe45 /CMakeLists.txt | |
parent | 3e371f7ea70b1c2e06e1af50c3b41efdecbd072b (diff) |
Android: Show build version and date in Settings > About
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 11 |
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 42927c99..0312e115 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -28,6 +28,11 @@ if (IOS) | |||
28 | set (IOS_BUNDLE_VERSION 9) | 28 | set (IOS_BUNDLE_VERSION 9) |
29 | set (IOS_BUILD_DATE "2022-01-01") | 29 | set (IOS_BUILD_DATE "2022-01-01") |
30 | endif () | 30 | endif () |
31 | if (ANDROID) | ||
32 | set (PROJECT_VERSION 1.10) | ||
33 | set (ANDROID_BUILD_VERSION a3) # remember to update Gradle, AndroidManifest.xml | ||
34 | set (ANDROID_BUILD_DATE "2022-01-01") | ||
35 | endif () | ||
31 | 36 | ||
32 | # Defaults that depend on environment. | 37 | # Defaults that depend on environment. |
33 | set (DEFAULT_RESIZE_DRAW ON) | 38 | set (DEFAULT_RESIZE_DRAW ON) |
@@ -444,6 +449,12 @@ if (APPLE) | |||
444 | ) | 449 | ) |
445 | endif () | 450 | endif () |
446 | endif () | 451 | endif () |
452 | if (ANDROID) | ||
453 | target_compile_definitions (app PUBLIC | ||
454 | LAGRANGE_ANDROID_VERSION="${ANDROID_BUILD_VERSION}" | ||
455 | LAGRANGE_ANDROID_BUILD_DATE="${ANDROID_BUILD_DATE}" | ||
456 | ) | ||
457 | endif () | ||
447 | if (MSYS) | 458 | if (MSYS) |
448 | target_link_libraries (app PUBLIC d2d1 uuid dwmapi) # querying DPI | 459 | target_link_libraries (app PUBLIC d2d1 uuid dwmapi) # querying DPI |
449 | if (ENABLE_WINSPARKLE) | 460 | if (ENABLE_WINSPARKLE) |