diff options
author | Jaakko Keränen <jaakko.keranen@iki.fi> | 2021-11-07 12:42:59 +0200 |
---|---|---|
committer | Jaakko Keränen <jaakko.keranen@iki.fi> | 2021-11-07 12:42:59 +0200 |
commit | 159639b9f1d351a883127ff55ac93d814e430067 (patch) | |
tree | 725d15e7644ff1c4284fbe31216f8efcdacf4dbf /CMakeLists.txt | |
parent | 9fbb99e298aed79ae6a6f968594604699bb6c35d (diff) |
Windows: Call the updater; added a missing resources
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 7 |
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 41c1b392..b0d8f70c 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -54,6 +54,7 @@ option (ENABLE_RELATIVE_EMBED "Resources should always be found via relative p | |||
54 | option (ENABLE_RESIZE_DRAW "Force window to redraw during resizing" ${DEFAULT_RESIZE_DRAW}) | 54 | option (ENABLE_RESIZE_DRAW "Force window to redraw during resizing" ${DEFAULT_RESIZE_DRAW}) |
55 | option (ENABLE_WEBP "Use libwebp to decode .webp images (via pkg-config)" ON) | 55 | option (ENABLE_WEBP "Use libwebp to decode .webp images (via pkg-config)" ON) |
56 | option (ENABLE_WINDOWPOS_FIX "Set position after showing window (workaround for SDL bug)" OFF) | 56 | option (ENABLE_WINDOWPOS_FIX "Set position after showing window (workaround for SDL bug)" OFF) |
57 | option (ENABLE_WINSPARKLE "Use WinSparkle for automatic updates" OFF) | ||
57 | option (ENABLE_X11_SWRENDER "Use software rendering (X11)" OFF) | 58 | option (ENABLE_X11_SWRENDER "Use software rendering (X11)" OFF) |
58 | 59 | ||
59 | include (BuildType.cmake) | 60 | include (BuildType.cmake) |
@@ -149,6 +150,8 @@ set (SOURCES | |||
149 | src/stb_image.h | 150 | src/stb_image.h |
150 | src/stb_image_resize.h | 151 | src/stb_image_resize.h |
151 | src/stb_truetype.h | 152 | src/stb_truetype.h |
153 | src/updater.c | ||
154 | src/updater.h | ||
152 | src/visited.c | 155 | src/visited.c |
153 | src/visited.h | 156 | src/visited.h |
154 | # Audio playback: | 157 | # Audio playback: |
@@ -403,6 +406,10 @@ if (APPLE) | |||
403 | endif () | 406 | endif () |
404 | if (MSYS) | 407 | if (MSYS) |
405 | target_link_libraries (app PUBLIC d2d1 uuid dwmapi) # querying DPI | 408 | target_link_libraries (app PUBLIC d2d1 uuid dwmapi) # querying DPI |
409 | if (ENABLE_WINSPARKLE) | ||
410 | target_link_libraries (app PUBLIC winsparkle) | ||
411 | target_compile_definitions (app PUBLIC LAGRANGE_ENABLE_WINSPARKLE=1) | ||
412 | endif () | ||
406 | endif () | 413 | endif () |
407 | if (UNIX) | 414 | if (UNIX) |
408 | target_link_libraries (app PUBLIC m) | 415 | target_link_libraries (app PUBLIC m) |