summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaakko Keränen <jaakko.keranen@iki.fi>2021-08-20 06:36:07 +0300
committerJaakko Keränen <jaakko.keranen@iki.fi>2021-08-20 06:36:07 +0300
commit4e62a21cea5781fc91ec5ef22710e0fe19badb3c (patch)
treedc688c51fcec9f990796b4e58f0422dc25935954 /CMakeLists.txt
parentc4fa62d07dac1c3855dae4ed5108ab0f3eb43ceb (diff)
parentd358811295527f705defbeea31b38fa2ee90a12e (diff)
Merge branch 'dev' into work/v1.7
# Conflicts: # CMakeLists.txt
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fc0835f1..73e2b8d4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,6 +28,12 @@ if (IOS)
28 set (IOS_BUNDLE_VERSION 21.6.15) 28 set (IOS_BUNDLE_VERSION 21.6.15)
29endif () 29endif ()
30 30
31# Default that depend on environment.
32set (DEFAULT_RESIZE_DRAW ON)
33if (HAIKU)
34 set (DEFAULT_RESIZE_DRAW OFF)
35endif ()
36
31# Build configuration. 37# Build configuration.
32option (ENABLE_CUSTOM_FRAME "Draw a custom window frame (Windows)" OFF) 38option (ENABLE_CUSTOM_FRAME "Draw a custom window frame (Windows)" OFF)
33option (ENABLE_DOWNLOAD_EDIT "Allow changing the Downloads directory" ON) 39option (ENABLE_DOWNLOAD_EDIT "Allow changing the Downloads directory" ON)
@@ -40,6 +46,7 @@ option (ENABLE_IPC "Use IPC to communicate between running instance
40option (ENABLE_KERNING "Enable kerning in font renderer (slower)" ON) 46option (ENABLE_KERNING "Enable kerning in font renderer (slower)" ON)
41option (ENABLE_MPG123 "Use mpg123 for decoding MPEG audio" ON) 47option (ENABLE_MPG123 "Use mpg123 for decoding MPEG audio" ON)
42option (ENABLE_RELATIVE_EMBED "Resources should always be found via relative path" OFF) 48option (ENABLE_RELATIVE_EMBED "Resources should always be found via relative path" OFF)
49option (ENABLE_RESIZE_DRAW "Force window to redraw during resizing" ${DEFAULT_RESIZE_DRAW})
43option (ENABLE_RESOURCE_EMBED "Embed resources inside the executable" OFF) 50option (ENABLE_RESOURCE_EMBED "Embed resources inside the executable" OFF)
44option (ENABLE_WINDOWPOS_FIX "Set position after showing window (workaround for SDL bug)" OFF) 51option (ENABLE_WINDOWPOS_FIX "Set position after showing window (workaround for SDL bug)" OFF)
45option (ENABLE_X11_SWRENDER "Use software rendering under X11" OFF) 52option (ENABLE_X11_SWRENDER "Use software rendering under X11" OFF)
@@ -317,6 +324,9 @@ endif ()
317if (ENABLE_CUSTOM_FRAME AND MSYS) 324if (ENABLE_CUSTOM_FRAME AND MSYS)
318 target_compile_definitions (app PUBLIC LAGRANGE_ENABLE_CUSTOM_FRAME=1) 325 target_compile_definitions (app PUBLIC LAGRANGE_ENABLE_CUSTOM_FRAME=1)
319endif () 326endif ()
327if (ENABLE_RESIZE_DRAW)
328 target_compile_definitions (app PUBLIC LAGRANGE_ENABLE_RESIZE_DRAW=1)
329endif ()
320target_link_libraries (app PUBLIC the_Foundation::the_Foundation) 330target_link_libraries (app PUBLIC the_Foundation::the_Foundation)
321target_link_libraries (app PUBLIC ${SDL2_LDFLAGS}) 331target_link_libraries (app PUBLIC ${SDL2_LDFLAGS})
322if (ENABLE_HARFBUZZ AND HARFBUZZ_FOUND) 332if (ENABLE_HARFBUZZ AND HARFBUZZ_FOUND)