diff options
author | Jaakko Keränen <jaakko.keranen@iki.fi> | 2021-08-20 06:36:07 +0300 |
---|---|---|
committer | Jaakko Keränen <jaakko.keranen@iki.fi> | 2021-08-20 06:36:07 +0300 |
commit | 4e62a21cea5781fc91ec5ef22710e0fe19badb3c (patch) | |
tree | dc688c51fcec9f990796b4e58f0422dc25935954 /CMakeLists.txt | |
parent | c4fa62d07dac1c3855dae4ed5108ab0f3eb43ceb (diff) | |
parent | d358811295527f705defbeea31b38fa2ee90a12e (diff) |
Merge branch 'dev' into work/v1.7
# Conflicts:
# CMakeLists.txt
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 10 |
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index fc0835f1..73e2b8d4 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -28,6 +28,12 @@ if (IOS) | |||
28 | set (IOS_BUNDLE_VERSION 21.6.15) | 28 | set (IOS_BUNDLE_VERSION 21.6.15) |
29 | endif () | 29 | endif () |
30 | 30 | ||
31 | # Default that depend on environment. | ||
32 | set (DEFAULT_RESIZE_DRAW ON) | ||
33 | if (HAIKU) | ||
34 | set (DEFAULT_RESIZE_DRAW OFF) | ||
35 | endif () | ||
36 | |||
31 | # Build configuration. | 37 | # Build configuration. |
32 | option (ENABLE_CUSTOM_FRAME "Draw a custom window frame (Windows)" OFF) | 38 | option (ENABLE_CUSTOM_FRAME "Draw a custom window frame (Windows)" OFF) |
33 | option (ENABLE_DOWNLOAD_EDIT "Allow changing the Downloads directory" ON) | 39 | option (ENABLE_DOWNLOAD_EDIT "Allow changing the Downloads directory" ON) |
@@ -40,6 +46,7 @@ option (ENABLE_IPC "Use IPC to communicate between running instance | |||
40 | option (ENABLE_KERNING "Enable kerning in font renderer (slower)" ON) | 46 | option (ENABLE_KERNING "Enable kerning in font renderer (slower)" ON) |
41 | option (ENABLE_MPG123 "Use mpg123 for decoding MPEG audio" ON) | 47 | option (ENABLE_MPG123 "Use mpg123 for decoding MPEG audio" ON) |
42 | option (ENABLE_RELATIVE_EMBED "Resources should always be found via relative path" OFF) | 48 | option (ENABLE_RELATIVE_EMBED "Resources should always be found via relative path" OFF) |
49 | option (ENABLE_RESIZE_DRAW "Force window to redraw during resizing" ${DEFAULT_RESIZE_DRAW}) | ||
43 | option (ENABLE_RESOURCE_EMBED "Embed resources inside the executable" OFF) | 50 | option (ENABLE_RESOURCE_EMBED "Embed resources inside the executable" OFF) |
44 | option (ENABLE_WINDOWPOS_FIX "Set position after showing window (workaround for SDL bug)" OFF) | 51 | option (ENABLE_WINDOWPOS_FIX "Set position after showing window (workaround for SDL bug)" OFF) |
45 | option (ENABLE_X11_SWRENDER "Use software rendering under X11" OFF) | 52 | option (ENABLE_X11_SWRENDER "Use software rendering under X11" OFF) |
@@ -317,6 +324,9 @@ endif () | |||
317 | if (ENABLE_CUSTOM_FRAME AND MSYS) | 324 | if (ENABLE_CUSTOM_FRAME AND MSYS) |
318 | target_compile_definitions (app PUBLIC LAGRANGE_ENABLE_CUSTOM_FRAME=1) | 325 | target_compile_definitions (app PUBLIC LAGRANGE_ENABLE_CUSTOM_FRAME=1) |
319 | endif () | 326 | endif () |
327 | if (ENABLE_RESIZE_DRAW) | ||
328 | target_compile_definitions (app PUBLIC LAGRANGE_ENABLE_RESIZE_DRAW=1) | ||
329 | endif () | ||
320 | target_link_libraries (app PUBLIC the_Foundation::the_Foundation) | 330 | target_link_libraries (app PUBLIC the_Foundation::the_Foundation) |
321 | target_link_libraries (app PUBLIC ${SDL2_LDFLAGS}) | 331 | target_link_libraries (app PUBLIC ${SDL2_LDFLAGS}) |
322 | if (ENABLE_HARFBUZZ AND HARFBUZZ_FOUND) | 332 | if (ENABLE_HARFBUZZ AND HARFBUZZ_FOUND) |