diff options
author | Jaakko Keränen <jaakko.keranen@iki.fi> | 2021-10-31 09:27:10 +0200 |
---|---|---|
committer | Jaakko Keränen <jaakko.keranen@iki.fi> | 2021-10-31 09:27:21 +0200 |
commit | 818035caed2f982279fb0837effcdce08122bc59 (patch) | |
tree | 580f50eb38f0d54ae4fd30a45568001d19300674 /CMakeLists.txt | |
parent | 1e7e9e190b63b9f21709c3822e4cd197ab34e7f4 (diff) |
Cleanup
Removed extra font installation from CMakeLists. These are available separately and not managed by CMake.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 27 |
1 files changed, 0 insertions, 27 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index f5f2d65a..4cafc4fa 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -65,25 +65,6 @@ include (Depends.cmake) | |||
65 | # Package resources. | 65 | # Package resources. |
66 | message (STATUS "Preparing resources...") | 66 | message (STATUS "Preparing resources...") |
67 | make_fontpack (res/default.fontpack) | 67 | make_fontpack (res/default.fontpack) |
68 | # Fonts to install as separate files. | ||
69 | set (FONTPACKS | ||
70 | # arabic.fontpack | ||
71 | # cjk.fontpack | ||
72 | # firasans.fontpack | ||
73 | # literata.fontpack | ||
74 | # nunito.fontpack | ||
75 | # tinos.fontpack | ||
76 | ) | ||
77 | foreach (fp ${FONTPACKS}) | ||
78 | make_fontpack (res/${fp}) | ||
79 | set_source_files_properties (${CMAKE_BINARY_DIR}/${fp} | ||
80 | PROPERTIES MACOSX_PACKAGE_LOCATION Resources) | ||
81 | endforeach (fp) | ||
82 | macro (install_fonts dst) | ||
83 | foreach (fp ${FONTPACKS}) | ||
84 | install (FILES ${CMAKE_BINARY_DIR}/${fp} DESTINATION ${dst}) | ||
85 | endforeach (fp) | ||
86 | endmacro () | ||
87 | set (EMBED_RESOURCES | 68 | set (EMBED_RESOURCES |
88 | res/about/about.gmi | 69 | res/about/about.gmi |
89 | res/about/help.gmi | 70 | res/about/help.gmi |
@@ -240,11 +221,6 @@ set (SOURCES | |||
240 | ${CMAKE_CURRENT_BINARY_DIR}/embedded.h | 221 | ${CMAKE_CURRENT_BINARY_DIR}/embedded.h |
241 | ${CMAKE_CURRENT_BINARY_DIR}/resources.lgr | 222 | ${CMAKE_CURRENT_BINARY_DIR}/resources.lgr |
242 | ) | 223 | ) |
243 | if (APPLE) | ||
244 | foreach (fp ${FONTPACKS}) | ||
245 | list (APPEND SOURCES ${CMAKE_BINARY_DIR}/${fp}) | ||
246 | endforeach (fp) | ||
247 | endif () | ||
248 | if (ENABLE_IPC) | 224 | if (ENABLE_IPC) |
249 | list (APPEND SOURCES | 225 | list (APPEND SOURCES |
250 | src/ipc.c | 226 | src/ipc.c |
@@ -444,7 +420,6 @@ if (MSYS) | |||
444 | if (NOT ENABLE_RESOURCE_EMBED) | 420 | if (NOT ENABLE_RESOURCE_EMBED) |
445 | install (FILES ${EMB_BIN} DESTINATION .) | 421 | install (FILES ${EMB_BIN} DESTINATION .) |
446 | endif () | 422 | endif () |
447 | install_fonts (.) | ||
448 | install (PROGRAMS | 423 | install (PROGRAMS |
449 | ${SDL2_LIBDIR}/SDL2.dll | 424 | ${SDL2_LIBDIR}/SDL2.dll |
450 | res/urlopen.bat | 425 | res/urlopen.bat |
@@ -460,7 +435,6 @@ elseif (HAIKU) | |||
460 | LAGRANGE_EMB_BIN="${CMAKE_INSTALL_PREFIX}/resources.lgr") | 435 | LAGRANGE_EMB_BIN="${CMAKE_INSTALL_PREFIX}/resources.lgr") |
461 | install (FILES ${EMB_BIN} DESTINATION .) | 436 | install (FILES ${EMB_BIN} DESTINATION .) |
462 | endif () | 437 | endif () |
463 | install_fonts (.) | ||
464 | elseif (UNIX AND NOT APPLE) | 438 | elseif (UNIX AND NOT APPLE) |
465 | set_target_properties (app PROPERTIES | 439 | set_target_properties (app PROPERTIES |
466 | INSTALL_RPATH_USE_LINK_PATH YES | 440 | INSTALL_RPATH_USE_LINK_PATH YES |
@@ -493,5 +467,4 @@ MimeType=x-scheme-handler/gemini;x-scheme-handler/gopher | |||
493 | endif () | 467 | endif () |
494 | install (FILES ${EMB_BIN} DESTINATION share/lagrange) | 468 | install (FILES ${EMB_BIN} DESTINATION share/lagrange) |
495 | endif () | 469 | endif () |
496 | install_fonts (share/lagrange) | ||
497 | endif () | 470 | endif () |