diff options
author | Jaakko Keränen <jaakko.keranen@iki.fi> | 2021-08-17 13:00:15 +0300 |
---|---|---|
committer | Jaakko Keränen <jaakko.keranen@iki.fi> | 2021-08-17 13:00:21 +0300 |
commit | e1930b58579da943d985005b05ec97a5def7ac93 (patch) | |
tree | 81d85a7525b1d28d1b7857e808eda1dbadfb6c50 /CMakeLists.txt | |
parent | f845df7ae781cd658725c657520024826e9bee9f (diff) |
Added build option for window drawing during resize
The option defaults to OFF because generally SDL should be handling this and the resize watcher is a bit of hack.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 6 |
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index c9037986..385703d9 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -18,7 +18,7 @@ | |||
18 | cmake_minimum_required (VERSION 3.9) | 18 | cmake_minimum_required (VERSION 3.9) |
19 | 19 | ||
20 | project (Lagrange | 20 | project (Lagrange |
21 | VERSION 1.6.3 | 21 | VERSION 1.6.4 |
22 | DESCRIPTION "A Beautiful Gemini Client" | 22 | DESCRIPTION "A Beautiful Gemini Client" |
23 | LANGUAGES C | 23 | LANGUAGES C |
24 | ) | 24 | ) |
@@ -40,6 +40,7 @@ option (ENABLE_IPC "Use IPC to communicate between running instance | |||
40 | option (ENABLE_KERNING "Enable kerning in font renderer (slower)" ON) | 40 | option (ENABLE_KERNING "Enable kerning in font renderer (slower)" ON) |
41 | option (ENABLE_MPG123 "Use mpg123 for decoding MPEG audio" ON) | 41 | option (ENABLE_MPG123 "Use mpg123 for decoding MPEG audio" ON) |
42 | option (ENABLE_RELATIVE_EMBED "Resources should always be found via relative path" OFF) | 42 | option (ENABLE_RELATIVE_EMBED "Resources should always be found via relative path" OFF) |
43 | option (ENABLE_RESIZE_DRAW "Force window to redraw during resizing" OFF) | ||
43 | option (ENABLE_RESOURCE_EMBED "Embed resources inside the executable" OFF) | 44 | option (ENABLE_RESOURCE_EMBED "Embed resources inside the executable" OFF) |
44 | option (ENABLE_WINDOWPOS_FIX "Set position after showing window (workaround for SDL bug)" OFF) | 45 | option (ENABLE_WINDOWPOS_FIX "Set position after showing window (workaround for SDL bug)" OFF) |
45 | option (ENABLE_X11_SWRENDER "Use software rendering under X11" OFF) | 46 | option (ENABLE_X11_SWRENDER "Use software rendering under X11" OFF) |
@@ -315,6 +316,9 @@ endif () | |||
315 | if (ENABLE_CUSTOM_FRAME AND MSYS) | 316 | if (ENABLE_CUSTOM_FRAME AND MSYS) |
316 | target_compile_definitions (app PUBLIC LAGRANGE_ENABLE_CUSTOM_FRAME=1) | 317 | target_compile_definitions (app PUBLIC LAGRANGE_ENABLE_CUSTOM_FRAME=1) |
317 | endif () | 318 | endif () |
319 | if (ENABLE_RESIZE_DRAW) | ||
320 | target_compile_definitions (app PUBLIC LAGRANGE_ENABLE_RESIZE_DRAW=1) | ||
321 | endif () | ||
318 | target_link_libraries (app PUBLIC the_Foundation::the_Foundation) | 322 | target_link_libraries (app PUBLIC the_Foundation::the_Foundation) |
319 | target_link_libraries (app PUBLIC ${SDL2_LDFLAGS}) | 323 | target_link_libraries (app PUBLIC ${SDL2_LDFLAGS}) |
320 | if (ENABLE_HARFBUZZ AND HARFBUZZ_FOUND) | 324 | if (ENABLE_HARFBUZZ AND HARFBUZZ_FOUND) |