summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaakko Keränen <jaakko.keranen@iki.fi>2021-08-20 09:07:09 +0300
committerJaakko Keränen <jaakko.keranen@iki.fi>2021-08-20 09:07:09 +0300
commite9e496ffb64d83a55162d38ffc6d87a364bb6a95 (patch)
treea8a76c8bf63b24347e5d09582319db5eca4e7d88 /CMakeLists.txt
parent4e62a21cea5781fc91ec5ef22710e0fe19badb3c (diff)
Added WebP decoding using libwebp
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 73e2b8d4..262bbcb9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,6 +48,7 @@ option (ENABLE_MPG123 "Use mpg123 for decoding MPEG audio" ON)
48option (ENABLE_RELATIVE_EMBED "Resources should always be found via relative path" OFF) 48option (ENABLE_RELATIVE_EMBED "Resources should always be found via relative path" OFF)
49option (ENABLE_RESIZE_DRAW "Force window to redraw during resizing" ${DEFAULT_RESIZE_DRAW}) 49option (ENABLE_RESIZE_DRAW "Force window to redraw during resizing" ${DEFAULT_RESIZE_DRAW})
50option (ENABLE_RESOURCE_EMBED "Embed resources inside the executable" OFF) 50option (ENABLE_RESOURCE_EMBED "Embed resources inside the executable" OFF)
51option (ENABLE_WEBP "Use libwebp to decode .webp images (via pkg-config)" ON)
51option (ENABLE_WINDOWPOS_FIX "Set position after showing window (workaround for SDL bug)" OFF) 52option (ENABLE_WINDOWPOS_FIX "Set position after showing window (workaround for SDL bug)" OFF)
52option (ENABLE_X11_SWRENDER "Use software rendering under X11" OFF) 53option (ENABLE_X11_SWRENDER "Use software rendering under X11" OFF)
53 54
@@ -315,6 +316,10 @@ if (ENABLE_MPG123 AND MPG123_FOUND)
315 target_compile_definitions (app PUBLIC LAGRANGE_ENABLE_MPG123=1) 316 target_compile_definitions (app PUBLIC LAGRANGE_ENABLE_MPG123=1)
316 target_link_libraries (app PUBLIC PkgConfig::MPG123) 317 target_link_libraries (app PUBLIC PkgConfig::MPG123)
317endif () 318endif ()
319if (ENABLE_WEBP AND WEBP_FOUND)
320 target_compile_definitions (app PUBLIC LAGRANGE_ENABLE_WEBP=1)
321 target_link_libraries (app PUBLIC PkgConfig::WEBP)
322endif ()
318if (ENABLE_IDLE_SLEEP) 323if (ENABLE_IDLE_SLEEP)
319 target_compile_definitions (app PUBLIC LAGRANGE_ENABLE_IDLE_SLEEP=1) 324 target_compile_definitions (app PUBLIC LAGRANGE_ENABLE_IDLE_SLEEP=1)
320endif () 325endif ()