summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaakko Keränen <jaakko.keranen@iki.fi>2021-08-17 14:47:14 +0300
committerJaakko Keränen <jaakko.keranen@iki.fi>2021-08-17 14:47:14 +0300
commiteebca1a6f58a72faf38029aa687854feccf5b865 (patch)
treed8c028307cb8dbe8786437c8fc60fb5d5e9b4695 /CMakeLists.txt
parent19a0d3cbb7ca5b12057b195051de4ae8000c7a32 (diff)
Changed default of ENABLE_RESIZE_DRAW to ON
Resize drawing seems to work better on many platforms so default to ON.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 385703d9..c7b30719 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,6 +28,12 @@ if (IOS)
28 set (IOS_BUNDLE_VERSION 21.6.15) 28 set (IOS_BUNDLE_VERSION 21.6.15)
29endif () 29endif ()
30 30
31# Default that depend on environment.
32set (DEFAULT_RESIZE_DRAW ON)
33if (HAIKU)
34 set (DEFAULT_RESIZE_DRAW OFF)
35endif ()
36
31# Build configuration. 37# Build configuration.
32option (ENABLE_CUSTOM_FRAME "Draw a custom window frame (Windows)" OFF) 38option (ENABLE_CUSTOM_FRAME "Draw a custom window frame (Windows)" OFF)
33option (ENABLE_DOWNLOAD_EDIT "Allow changing the Downloads directory" ON) 39option (ENABLE_DOWNLOAD_EDIT "Allow changing the Downloads directory" ON)
@@ -40,7 +46,7 @@ option (ENABLE_IPC "Use IPC to communicate between running instance
40option (ENABLE_KERNING "Enable kerning in font renderer (slower)" ON) 46option (ENABLE_KERNING "Enable kerning in font renderer (slower)" ON)
41option (ENABLE_MPG123 "Use mpg123 for decoding MPEG audio" ON) 47option (ENABLE_MPG123 "Use mpg123 for decoding MPEG audio" ON)
42option (ENABLE_RELATIVE_EMBED "Resources should always be found via relative path" OFF) 48option (ENABLE_RELATIVE_EMBED "Resources should always be found via relative path" OFF)
43option (ENABLE_RESIZE_DRAW "Force window to redraw during resizing" OFF) 49option (ENABLE_RESIZE_DRAW "Force window to redraw during resizing" ${DEFAULT_RESIZE_DRAW})
44option (ENABLE_RESOURCE_EMBED "Embed resources inside the executable" OFF) 50option (ENABLE_RESOURCE_EMBED "Embed resources inside the executable" OFF)
45option (ENABLE_WINDOWPOS_FIX "Set position after showing window (workaround for SDL bug)" OFF) 51option (ENABLE_WINDOWPOS_FIX "Set position after showing window (workaround for SDL bug)" OFF)
46option (ENABLE_X11_SWRENDER "Use software rendering under X11" OFF) 52option (ENABLE_X11_SWRENDER "Use software rendering under X11" OFF)