summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJaakko Keränen <jaakko.keranen@iki.fi>2020-12-09 08:33:06 +0200
committerGitHub <noreply@github.com>2020-12-09 08:33:06 +0200
commit51c6438ff5abf0f40827d8278ecb847b80fd0997 (patch)
tree9363616aa9555cf22748a4115e800854301bce06 /debian/rules
parent29dc66896daef970cb1d03d0d01b7b7b35057a2a (diff)
parentb12d1c8d7a337e8ff6e3fa207ee45822c4a075ab (diff)
Merge pull request #95 from SolidHal/dev
Rework the debian/rules makefile to apply build flags to specific architectures, correct overrides
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules20
1 files changed, 17 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 9e306b0b..f85bd158 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,12 +1,26 @@
1#!/usr/bin/make -f 1#!/usr/bin/make -f
2export DH_VERBOSE = 1 2export DH_VERBOSE = 1
3export DEB_BUILD_MAINT_OPTIONS=hardening=-format 3export DEB_BUILD_MAINT_OPTIONS=hardening=-format
4export LAGRANGE_CMAKE_FLAGS= -DCMAKE_BUILD_TYPE=Release -DENABLE_WINDOWPOS_FIX=YES
5
6# SSE4.1 support (or lack thereof) is only a concern on x86_64/x86 machines
7ifeq ($(DEB_BUILD_ARCH), amd64)
8 LAGRANGE_CMAKE_FLAGS += -DTFDN_ENABLE_SSE41=NO
9else ifeq ($(DEB_BUILD_ARCH), i386)
10 LAGRANGE_CMAKE_FLAGS += -DTFDN_ENABLE_SSE41=NO
11endif
12
13# on non x86_64/x86, specifically armhf, arm64, arm, OpenGL hw acceleration under X11 is a bit too slow.
14ifneq ($(DEB_BUILD_ARCH), amd64)
15 LAGRANGE_CMAKE_FLAGS += -DENABLE_KERNING=NO -DENABLE_X11_SWRENDER=YES
16endif
17
4 18
5%: 19%:
6 dh $@ 20 dh $@
7 21
8override_dh_auto_configure: 22override_dh_auto_configure:
9 cmake .. -DCMAKE_BUILD_TYPE=Release -DENABLE_WINDOWPOS_FIX=YES -DTFDN_ENABLE_SSE41=NO -DCMAKE_INSTALL_PREFIX=$(pwd)/../usr 23 cmake . $(LAGRANGE_CMAKE_FLAGS) -DCMAKE_INSTALL_PREFIX=/usr/
10 24
11override_dh_build_configure: 25override_dh_auto_build:
12 cmake --build . 26 cmake --build .