diff options
author | Jaakko Keränen <jaakko.keranen@iki.fi> | 2020-11-02 08:17:45 +0200 |
---|---|---|
committer | Jaakko Keränen <jaakko.keranen@iki.fi> | 2020-11-02 11:11:24 +0200 |
commit | 3543fd0eaaf3ed0f068ed0012e9da8a6d500f298 (patch) | |
tree | 7f33456ea75f6b0f83fcbbf1368abdab256e305f /res/CMakeLists.txt | |
parent | 8605b747b3eac83e6af7907de7659bfb989d0358 (diff) |
Embed: Build resource files faster
As part of the CMake configuration, build bincat (23 lines of C) to concatenate resource files together. This is much faster because CMake doesn't have to get involved in the contents of the binary files.
Diffstat (limited to 'res/CMakeLists.txt')
-rw-r--r-- | res/CMakeLists.txt | 4 |
1 files changed, 4 insertions, 0 deletions
diff --git a/res/CMakeLists.txt b/res/CMakeLists.txt new file mode 100644 index 00000000..0a8c6260 --- /dev/null +++ b/res/CMakeLists.txt | |||
@@ -0,0 +1,4 @@ | |||
1 | # CMakeLists for bincat | ||
2 | cmake_minimum_required (VERSION 3.0) | ||
3 | project (BINCAT VERSION 1.0 LANGUAGES C) | ||
4 | add_executable (bincat bincat.c) | ||