summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ccdb1cc1..216ccfc0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -150,6 +150,8 @@ set (SOURCES
150 src/ui/sidebarwidget.h 150 src/ui/sidebarwidget.h
151 src/ui/text.c 151 src/ui/text.c
152 src/ui/text.h 152 src/ui/text.h
153 src/ui/touch.c
154 src/ui/touch.h
153 src/ui/util.c 155 src/ui/util.c
154 src/ui/util.h 156 src/ui/util.h
155 src/ui/visbuf.c 157 src/ui/visbuf.c
@@ -230,6 +232,9 @@ target_link_libraries (app PUBLIC ${SDL2_LDFLAGS})
230if (APPLE) 232if (APPLE)
231 if (IOS) 233 if (IOS)
232 target_link_libraries (app PUBLIC "-framework UIKit") 234 target_link_libraries (app PUBLIC "-framework UIKit")
235 set_target_properties (app PROPERTIES
236 XCODE_ATTRIBUTE_TARGETED_DEVICE_FAMILY 2
237 )
233 else () 238 else ()
234 target_link_libraries (app PUBLIC "-framework AppKit") 239 target_link_libraries (app PUBLIC "-framework AppKit")
235 endif () 240 endif ()