diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 1bb50791..4ac00ad3 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -294,6 +294,7 @@ elseif (APPLE) | |||
294 | add_definitions (-DiPlatformAppleDesktop=1) | 294 | add_definitions (-DiPlatformAppleDesktop=1) |
295 | list (APPEND SOURCES src/macos.m src/macos.h) | 295 | list (APPEND SOURCES src/macos.m src/macos.h) |
296 | list (APPEND RESOURCES "res/Lagrange.icns") | 296 | list (APPEND RESOURCES "res/Lagrange.icns") |
297 | set_source_files_properties ("res/Lagrange.icns" PROPERTIES MACOSX_PACKAGE_LOCATION Resources) | ||
297 | endif () | 298 | endif () |
298 | if (MSYS) | 299 | if (MSYS) |
299 | set (WINRC_FILE_VERSION ${PROJECT_VERSION_MAJOR},${PROJECT_VERSION_MINOR},${PROJECT_VERSION_PATCH},0) | 300 | set (WINRC_FILE_VERSION ${PROJECT_VERSION_MAJOR},${PROJECT_VERSION_MINOR},${PROJECT_VERSION_PATCH},0) |
@@ -301,7 +302,6 @@ if (MSYS) | |||
301 | configure_file (res/lagrange.rc.in ${CMAKE_CURRENT_BINARY_DIR}/lagrange.rc NEWLINE_STYLE WIN32) | 302 | configure_file (res/lagrange.rc.in ${CMAKE_CURRENT_BINARY_DIR}/lagrange.rc NEWLINE_STYLE WIN32) |
302 | list (APPEND SOURCES src/win32.c src/win32.h ${CMAKE_CURRENT_BINARY_DIR}/lagrange.rc) | 303 | list (APPEND SOURCES src/win32.c src/win32.h ${CMAKE_CURRENT_BINARY_DIR}/lagrange.rc) |
303 | endif () | 304 | endif () |
304 | #set_source_files_properties (${RESOURCES} PROPERTIES MACOSX_PACKAGE_LOCATION Resources) | ||
305 | if (MSYS OR (APPLE AND NOT MOBILE) OR (UNIX AND NOT MOBILE)) | 305 | if (MSYS OR (APPLE AND NOT MOBILE) OR (UNIX AND NOT MOBILE)) |
306 | add_definitions (-DiPlatformPcDesktop=1) | 306 | add_definitions (-DiPlatformPcDesktop=1) |
307 | endif () | 307 | endif () |