summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 100794d8..ce07c2de 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -31,6 +31,7 @@ option (ENABLE_KERNING "Enable kerning in font renderer (slower)" ON)
31option (ENABLE_RESOURCE_EMBED "Embed resources inside the executable" OFF) 31option (ENABLE_RESOURCE_EMBED "Embed resources inside the executable" OFF)
32option (ENABLE_WINDOWPOS_FIX "Set position after showing window (workaround for SDL bug)" OFF) 32option (ENABLE_WINDOWPOS_FIX "Set position after showing window (workaround for SDL bug)" OFF)
33option (ENABLE_IDLE_SLEEP "While idle, sleep in the main thread instead of waiting for events" ON) 33option (ENABLE_IDLE_SLEEP "While idle, sleep in the main thread instead of waiting for events" ON)
34option (ENABLE_DOWNLOAD_EDIT "Allow changing the Downloads directory" ON)
34 35
35include (BuildType.cmake) 36include (BuildType.cmake)
36include (res/Embed.cmake) 37include (res/Embed.cmake)
@@ -226,6 +227,9 @@ endif ()
226if (ENABLE_IDLE_SLEEP) 227if (ENABLE_IDLE_SLEEP)
227 target_compile_definitions (app PUBLIC LAGRANGE_IDLE_SLEEP=1) 228 target_compile_definitions (app PUBLIC LAGRANGE_IDLE_SLEEP=1)
228endif () 229endif ()
230if (ENABLE_DOWNLOAD_EDIT)
231 target_compile_definitions (app PUBLIC LAGRANGE_DOWNLOAD_EDIT=1)
232endif ()
229target_link_libraries (app PUBLIC the_Foundation::the_Foundation) 233target_link_libraries (app PUBLIC the_Foundation::the_Foundation)
230target_link_libraries (app PUBLIC ${SDL2_LDFLAGS}) 234target_link_libraries (app PUBLIC ${SDL2_LDFLAGS})
231if (APPLE) 235if (APPLE)