summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 18789f9c..22fe36f0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -285,7 +285,12 @@ else ()
285endif () 285endif ()
286 286
287# Target. 287# Target.
288add_executable (app ${SOURCES} ${RESOURCES}) 288if (NOT ANDROID)
289 add_executable (app ${SOURCES} ${RESOURCES})
290else ()
291 # The whole app becomes one shared library, based on this static one.
292 add_library (app STATIC ${SOURCES})
293endif ()
289set_property (TARGET app PROPERTY C_STANDARD 11) 294set_property (TARGET app PROPERTY C_STANDARD 11)
290if (TARGET ext-deps) 295if (TARGET ext-deps)
291 add_dependencies (app ext-deps) 296 add_dependencies (app ext-deps)