diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 5 |
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 73e2b8d4..262bbcb9 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -48,6 +48,7 @@ option (ENABLE_MPG123 "Use mpg123 for decoding MPEG audio" ON) | |||
48 | option (ENABLE_RELATIVE_EMBED "Resources should always be found via relative path" OFF) | 48 | option (ENABLE_RELATIVE_EMBED "Resources should always be found via relative path" OFF) |
49 | option (ENABLE_RESIZE_DRAW "Force window to redraw during resizing" ${DEFAULT_RESIZE_DRAW}) | 49 | option (ENABLE_RESIZE_DRAW "Force window to redraw during resizing" ${DEFAULT_RESIZE_DRAW}) |
50 | option (ENABLE_RESOURCE_EMBED "Embed resources inside the executable" OFF) | 50 | option (ENABLE_RESOURCE_EMBED "Embed resources inside the executable" OFF) |
51 | option (ENABLE_WEBP "Use libwebp to decode .webp images (via pkg-config)" ON) | ||
51 | option (ENABLE_WINDOWPOS_FIX "Set position after showing window (workaround for SDL bug)" OFF) | 52 | option (ENABLE_WINDOWPOS_FIX "Set position after showing window (workaround for SDL bug)" OFF) |
52 | option (ENABLE_X11_SWRENDER "Use software rendering under X11" OFF) | 53 | option (ENABLE_X11_SWRENDER "Use software rendering under X11" OFF) |
53 | 54 | ||
@@ -315,6 +316,10 @@ if (ENABLE_MPG123 AND MPG123_FOUND) | |||
315 | target_compile_definitions (app PUBLIC LAGRANGE_ENABLE_MPG123=1) | 316 | target_compile_definitions (app PUBLIC LAGRANGE_ENABLE_MPG123=1) |
316 | target_link_libraries (app PUBLIC PkgConfig::MPG123) | 317 | target_link_libraries (app PUBLIC PkgConfig::MPG123) |
317 | endif () | 318 | endif () |
319 | if (ENABLE_WEBP AND WEBP_FOUND) | ||
320 | target_compile_definitions (app PUBLIC LAGRANGE_ENABLE_WEBP=1) | ||
321 | target_link_libraries (app PUBLIC PkgConfig::WEBP) | ||
322 | endif () | ||
318 | if (ENABLE_IDLE_SLEEP) | 323 | if (ENABLE_IDLE_SLEEP) |
319 | target_compile_definitions (app PUBLIC LAGRANGE_ENABLE_IDLE_SLEEP=1) | 324 | target_compile_definitions (app PUBLIC LAGRANGE_ENABLE_IDLE_SLEEP=1) |
320 | endif () | 325 | endif () |