summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b62517c9..2621dc10 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -30,6 +30,7 @@ endif ()
30 30
31# Build configuration. 31# Build configuration.
32option (ENABLE_HARFBUZZ "Use HarfBuzz to shape text" ON) 32option (ENABLE_HARFBUZZ "Use HarfBuzz to shape text" ON)
33option (ENABLE_FRIBIDI "Use FriBidi for bidirectional text" ON)
33option (ENABLE_IPC "Use IPC to communicate between running instances" ON) 34option (ENABLE_IPC "Use IPC to communicate between running instances" ON)
34option (ENABLE_MPG123 "Use mpg123 for decoding MPEG audio" ON) 35option (ENABLE_MPG123 "Use mpg123 for decoding MPEG audio" ON)
35option (ENABLE_X11_SWRENDER "Use software rendering under X11" OFF) 36option (ENABLE_X11_SWRENDER "Use software rendering under X11" OFF)
@@ -319,6 +320,10 @@ if (ENABLE_HARFBUZZ AND HARFBUZZ_FOUND)
319 endif () 320 endif ()
320 target_compile_definitions (app PUBLIC LAGRANGE_ENABLE_HARFBUZZ=1) 321 target_compile_definitions (app PUBLIC LAGRANGE_ENABLE_HARFBUZZ=1)
321endif () 322endif ()
323if (ENABLE_FRIBIDI AND FRIBIDI_FOUND)
324 target_link_libraries (app PUBLIC fribidi-lib)
325 target_compile_definitions (app PUBLIC LAGRANGE_ENABLE_FRIBIDI=1)
326endif ()
322if (APPLE) 327if (APPLE)
323 if (IOS) 328 if (IOS)
324 target_link_libraries (app PUBLIC "-framework UIKit") 329 target_link_libraries (app PUBLIC "-framework UIKit")