diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 10 |
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 75883966..9fe62ba4 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -324,6 +324,9 @@ endif () | |||
324 | if (UNIX) | 324 | if (UNIX) |
325 | target_link_libraries (app PUBLIC m) | 325 | target_link_libraries (app PUBLIC m) |
326 | endif () | 326 | endif () |
327 | if (HAIKU) | ||
328 | target_link_libraries (app PUBLIC m network bsd) | ||
329 | endif () | ||
327 | 330 | ||
328 | # Deployment. | 331 | # Deployment. |
329 | if (MSYS) | 332 | if (MSYS) |
@@ -342,6 +345,13 @@ if (MSYS) | |||
342 | if (INSTALL_THE_FOUNDATION) | 345 | if (INSTALL_THE_FOUNDATION) |
343 | install (PROGRAMS $<TARGET_FILE:the_Foundation::the_Foundation> DESTINATION .) | 346 | install (PROGRAMS $<TARGET_FILE:the_Foundation::the_Foundation> DESTINATION .) |
344 | endif () | 347 | endif () |
348 | elseif (HAIKU) | ||
349 | install (TARGETS app DESTINATION .) | ||
350 | if (NOT ENABLE_RESOURCE_EMBED) | ||
351 | target_compile_definitions (app PUBLIC | ||
352 | LAGRANGE_EMB_BIN="${CMAKE_INSTALL_PREFIX}/resources.lgr") | ||
353 | install (FILES ${EMB_BIN} DESTINATION .) | ||
354 | endif () | ||
345 | elseif (UNIX AND NOT APPLE) | 355 | elseif (UNIX AND NOT APPLE) |
346 | set_target_properties (app PROPERTIES | 356 | set_target_properties (app PROPERTIES |
347 | INSTALL_RPATH_USE_LINK_PATH YES | 357 | INSTALL_RPATH_USE_LINK_PATH YES |