summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c9037986..385703d9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,7 +18,7 @@
18cmake_minimum_required (VERSION 3.9) 18cmake_minimum_required (VERSION 3.9)
19 19
20project (Lagrange 20project (Lagrange
21 VERSION 1.6.3 21 VERSION 1.6.4
22 DESCRIPTION "A Beautiful Gemini Client" 22 DESCRIPTION "A Beautiful Gemini Client"
23 LANGUAGES C 23 LANGUAGES C
24) 24)
@@ -40,6 +40,7 @@ option (ENABLE_IPC "Use IPC to communicate between running instance
40option (ENABLE_KERNING "Enable kerning in font renderer (slower)" ON) 40option (ENABLE_KERNING "Enable kerning in font renderer (slower)" ON)
41option (ENABLE_MPG123 "Use mpg123 for decoding MPEG audio" ON) 41option (ENABLE_MPG123 "Use mpg123 for decoding MPEG audio" ON)
42option (ENABLE_RELATIVE_EMBED "Resources should always be found via relative path" OFF) 42option (ENABLE_RELATIVE_EMBED "Resources should always be found via relative path" OFF)
43option (ENABLE_RESIZE_DRAW "Force window to redraw during resizing" OFF)
43option (ENABLE_RESOURCE_EMBED "Embed resources inside the executable" OFF) 44option (ENABLE_RESOURCE_EMBED "Embed resources inside the executable" OFF)
44option (ENABLE_WINDOWPOS_FIX "Set position after showing window (workaround for SDL bug)" OFF) 45option (ENABLE_WINDOWPOS_FIX "Set position after showing window (workaround for SDL bug)" OFF)
45option (ENABLE_X11_SWRENDER "Use software rendering under X11" OFF) 46option (ENABLE_X11_SWRENDER "Use software rendering under X11" OFF)
@@ -315,6 +316,9 @@ endif ()
315if (ENABLE_CUSTOM_FRAME AND MSYS) 316if (ENABLE_CUSTOM_FRAME AND MSYS)
316 target_compile_definitions (app PUBLIC LAGRANGE_ENABLE_CUSTOM_FRAME=1) 317 target_compile_definitions (app PUBLIC LAGRANGE_ENABLE_CUSTOM_FRAME=1)
317endif () 318endif ()
319if (ENABLE_RESIZE_DRAW)
320 target_compile_definitions (app PUBLIC LAGRANGE_ENABLE_RESIZE_DRAW=1)
321endif ()
318target_link_libraries (app PUBLIC the_Foundation::the_Foundation) 322target_link_libraries (app PUBLIC the_Foundation::the_Foundation)
319target_link_libraries (app PUBLIC ${SDL2_LDFLAGS}) 323target_link_libraries (app PUBLIC ${SDL2_LDFLAGS})
320if (ENABLE_HARFBUZZ AND HARFBUZZ_FOUND) 324if (ENABLE_HARFBUZZ AND HARFBUZZ_FOUND)