diff options
Diffstat (limited to 'debian/rules')
-rwxr-xr-x | debian/rules | 20 |
1 files changed, 17 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules index 9e306b0b..f85bd158 100755 --- a/debian/rules +++ b/debian/rules | |||
@@ -1,12 +1,26 @@ | |||
1 | #!/usr/bin/make -f | 1 | #!/usr/bin/make -f |
2 | export DH_VERBOSE = 1 | 2 | export DH_VERBOSE = 1 |
3 | export DEB_BUILD_MAINT_OPTIONS=hardening=-format | 3 | export DEB_BUILD_MAINT_OPTIONS=hardening=-format |
4 | export LAGRANGE_CMAKE_FLAGS= -DCMAKE_BUILD_TYPE=Release -DENABLE_WINDOWPOS_FIX=YES | ||
5 | |||
6 | # SSE4.1 support (or lack thereof) is only a concern on x86_64/x86 machines | ||
7 | ifeq ($(DEB_BUILD_ARCH), amd64) | ||
8 | LAGRANGE_CMAKE_FLAGS += -DTFDN_ENABLE_SSE41=NO | ||
9 | else ifeq ($(DEB_BUILD_ARCH), i386) | ||
10 | LAGRANGE_CMAKE_FLAGS += -DTFDN_ENABLE_SSE41=NO | ||
11 | endif | ||
12 | |||
13 | # on non x86_64/x86, specifically armhf, arm64, arm, OpenGL hw acceleration under X11 is a bit too slow. | ||
14 | ifneq ($(DEB_BUILD_ARCH), amd64) | ||
15 | LAGRANGE_CMAKE_FLAGS += -DENABLE_KERNING=NO -DENABLE_X11_SWRENDER=YES | ||
16 | endif | ||
17 | |||
4 | 18 | ||
5 | %: | 19 | %: |
6 | dh $@ | 20 | dh $@ |
7 | 21 | ||
8 | override_dh_auto_configure: | 22 | override_dh_auto_configure: |
9 | cmake .. -DCMAKE_BUILD_TYPE=Release -DENABLE_WINDOWPOS_FIX=YES -DTFDN_ENABLE_SSE41=NO -DCMAKE_INSTALL_PREFIX=$(pwd)/../usr | 23 | cmake . $(LAGRANGE_CMAKE_FLAGS) -DCMAKE_INSTALL_PREFIX=/usr/ |
10 | 24 | ||
11 | override_dh_build_configure: | 25 | override_dh_auto_build: |
12 | cmake --build . | 26 | cmake --build . |