summaryrefslogtreecommitdiff
path: root/fuzz/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'fuzz/CMakeLists.txt')
-rw-r--r--fuzz/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/fuzz/CMakeLists.txt b/fuzz/CMakeLists.txt
new file mode 100644
index 0000000..ad30aa3
--- /dev/null
+++ b/fuzz/CMakeLists.txt
@@ -0,0 +1,44 @@
1# Copyright (c) 2019 Yubico AB. All rights reserved.
2# Use of this source code is governed by a BSD-style
3# license that can be found in the LICENSE file.
4
5list(APPEND COMPAT_SOURCES
6 ../openbsd-compat/strlcpy.c
7 ../openbsd-compat/strlcat.c
8)
9
10list(APPEND COMMON_SOURCES
11 mutator_aux.c
12 uniform_random.c
13)
14
15
16# fuzz_cred
17add_executable(fuzz_cred fuzz_cred.c ${COMMON_SOURCES} ${COMPAT_SOURCES})
18target_compile_options(fuzz_cred PRIVATE ${FUZZ_LDFLAGS})
19set_target_properties(fuzz_cred PROPERTIES LINK_FLAGS ${FUZZ_LDFLAGS})
20target_link_libraries(fuzz_cred fido2_shared)
21
22# fuzz_assert
23add_executable(fuzz_assert fuzz_assert.c ${COMMON_SOURCES} ${COMPAT_SOURCES})
24target_compile_options(fuzz_assert PRIVATE ${FUZZ_LDFLAGS})
25set_target_properties(fuzz_assert PROPERTIES LINK_FLAGS ${FUZZ_LDFLAGS})
26target_link_libraries(fuzz_assert fido2_shared)
27
28# fuzz_mgmt
29add_executable(fuzz_mgmt fuzz_mgmt.c ${COMMON_SOURCES} ${COMPAT_SOURCES})
30target_compile_options(fuzz_mgmt PRIVATE ${FUZZ_LDFLAGS})
31set_target_properties(fuzz_mgmt PROPERTIES LINK_FLAGS ${FUZZ_LDFLAGS})
32target_link_libraries(fuzz_mgmt fido2_shared)
33
34# fuzz_credman
35add_executable(fuzz_credman fuzz_credman.c ${COMMON_SOURCES} ${COMPAT_SOURCES})
36target_compile_options(fuzz_credman PRIVATE ${FUZZ_LDFLAGS})
37set_target_properties(fuzz_credman PROPERTIES LINK_FLAGS ${FUZZ_LDFLAGS})
38target_link_libraries(fuzz_credman fido2_shared)
39
40# fuzz_bio
41add_executable(fuzz_bio fuzz_bio.c ${COMMON_SOURCES} ${COMPAT_SOURCES})
42target_compile_options(fuzz_bio PRIVATE ${FUZZ_LDFLAGS})
43set_target_properties(fuzz_bio PROPERTIES LINK_FLAGS ${FUZZ_LDFLAGS})
44target_link_libraries(fuzz_bio fido2_shared)